A - 1001

Description

There is a mysterious organization called Time-Space Administrative Bureau (TSAB) in the deep universe that we humans have not discovered yet. This year, the TSAB decided to elect an outstanding member from its elite troops. The elected guy will be honored with the title of "Ace of Aces".

After voting, the TSAB received N valid tickets. On each ticket, there is a number Ai denoting the ID of a candidate. The candidate with the most tickets nominated will be elected as the "Ace of Aces". If there are two or more candidates have the same number of nominations, no one will win.

Please write program to help TSAB determine who will be the "Ace of Aces".

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains an integer N (1 <= N <= 1000). The next line contains N integers Ai (1 <= Ai <= 1000).

Output

For each test case, output the ID of the candidate who will be honored with "Ace of Aces". If no one win the election, output "Nobody" (without quotes) instead.

Sample Input

3
5
2 2 2 1 1
5
1 1 2 2 3
1
998

Sample Output

2
Nobody
998


题意:

任意输入几组测试数据,每组数据先输入人数,然后再输入每个人所投票人的序号,如果有两个人或两个人以上得到相同的最多的票数,则输出Nobody,否则就输出最大的那个人的序号!

思路:

题目比较水,开一个数组,将其置为0,然后记录每个人所得票的个数,然后找到最大的那个,在寻找是否有与其相同的即可.

细节:

注意一些for函数的运用,在寻找是否有得到相同的最大票数时,可以定义一个标志!

代码:

#include <bits/stdc++.h>
using namespace std;
int main()
{
	int a[1001]={0},i,j,k,n,max,s,b,t;
	int flag=0;
	cin>>t;
	for(i=0;i<t;i++)
	{
	    for(j=0;j<1001;j++)
	    a[j]=0;
		cin>>n;
		for(j=0;j<n;j++)
		{
			cin>>k;
			a[k]++;
		}
		max=0;
		for(b=0;b<1001;b++)
		{
			if(a[b]>max)
			{
				max=a[b];
				s=b;
			}
		}
		for(j=0;j<1001;j++)
		{
			if(a[j]==max)
	   	flag++;
		}
	
		if(flag>1)						cout<<"Nobody"<<endl;
		else 
		cout<<s<<endl;
		flag=0;
		}
		return 0;
	}

心得:

题目较水,但是一定要仔细,要提高一次AC的能力


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值