Wooden Sticks HDU(贪心)

Problem Description
There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows: 


(a) The setup time for the first wooden stick is 1 minute. 
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l<=l' and w<=w'. Otherwise, it will need 1 minute for setup. 


You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).
 


Input
The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.
 


Output
The output should contain the minimum setup time in minutes, one per line.
 


Sample Input


4 9 5 2 2 1 3 5 1 4 

2 2 1 1 2 2 

1 3 2 2 3 1
 


Sample Output
2
1
3
 


Source
Asia 2001, Taejon (South Korea)

题意:

n根木材长l重w,前一根木材大于后一根的话要浪费一分钟准备机器,求最省方案!

思路:   贪心QAQ

首先对数据进行自定义排序,按长度 

由小到大排序,注意当长度相等时,按宽度从小到大排序!!!然后开一个数组用来记录木头是否处理过,然后定一个flag,一开始置为0,如果仍有未使用的木头,则变为0,用一个while语句,当flag始终为1时,则结束while.大题思路就是先使用一个变量,来记录没使用的第一个木头,然后在往后寻找符合条件得。

代码:

#include <bits/stdc++.h>
using namespace std;
struct wooden
{
	int l;
	int w;
}a[5001];
bool used[5001];//记录使用过的
bool cmp(wooden a,wooden b)
{
	if(a.l!=b.l)
	return a.l<b.l;
	else 
	return a.w<b.w;
}
	
int main()
{
	vector<wooden>v;
	int t,n,i,j;
	int s,flag;
	int sum;
	cin>>t;
	while(t--)
	{
		memset(used,0,sizeof(used));
		used[0]=1;
		s=0;
		sum=0;
		cin>>n;
		for(i=0;i<n;i++)
			cin>>a[i].l>>a[i].w;
			sort(a,a+n,cmp);
			while(1)
			{
				++sum;	for(i=s+1,j=s,flag=1;i<n;i++)
			{
				if(used[i])//使用过的
				continue;	
				if(a[j].l<=a[i].l&&a[j].w<=a[i].w)
			{
				used[i]=1;
				j=i;//使j变为i,
			}
			else 
			{
				if(flag)
				{
					s=i;
					flag=0;
				}
			}
			
			}
			if(flag)//没有
			break;
			}
			cout<<sum<<endl;
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值