POJ 3468 A Simple Problem with Integers----线段树

Time Limit: 5000MS Memory Limit: 131072K
Total Submissions: 138240 Accepted: 42813
Case Time Limit: 2000MS

Description

You have N integers, A1, A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1, A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of Aa, Aa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of Aa, Aa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15

Hint

The sums may exceed the range of 32-bit integers.

题意:对[1,n]区间进行区间修改和区间查询。简单的线段树套用模板问题。

#include <iostream>
#include <stdio.h>
#include <string.h>
#define ll long long
#define maxn 100000+5
using namespace std;
ll sum[maxn<<2],Add[maxn<<2];
void pushup(int rt)
{
    sum[rt]=sum[rt<<1]+sum[rt<<1|1];
}
void build(int l,int r,int rt)
{
    if(l==r){
        scanf("%lld",&sum[rt]);
        return ;
    }
    int m=(l+r)>>1;
    build(l,m,rt<<1);
    build(m+1,r,rt<<1|1);
    pushup(rt);
}
void pushdown(int rt,int ln,int rn)
{
    if(Add[rt]){
        Add[rt<<1]+=Add[rt];
        Add[rt<<1|1]+=Add[rt];
        sum[rt<<1]+=Add[rt]*ln;
        sum[rt<<1|1]+=Add[rt]*rn;
        Add[rt]=0;
    }
}

void updata(int L,int R,int C,int l,int r,int rt)
{
    if(L<=l&&r<=R){
        sum[rt]+=C*(r-l+1);
        Add[rt]+=C;
        return ;
    }
    int m=(l+r)>>1;
    pushdown(rt,m-l+1,r-m);
    if(L<=m)updata(L,R,C,l,m,rt<<1);
    if(R>m)updata(L,R,C,m+1,r,rt<<1|1);
    pushup(rt);
}
ll query(int L,int R,int l,int r,int rt)
{
    if(L<=l&&r<=R)return sum[rt];
    int m=(l+r)>>1;
    pushdown(rt,m-l+1,r-m);
    ll ans=0;
    if(L<=m)ans+=query(L,R,l,m,rt<<1);
    if(R>m)ans+=query(L,R,m+1,r,rt<<1|1);
    return ans;
}
int main()
{

    int n,q,x,y,d;
    scanf("%d%d",&n,&q);
    char a;
    build(1,n,1);
    getchar();
    for(int i=0;i<q;i++)
    {
        scanf("%c",&a);
        if(a=='Q'){
                scanf("%d%d",&x,&y);
        printf("%lld\n",query(x,y,1,n,1));
        }
        if(a=='C'){
                scanf("%d%d%d",&x,&y,&d);
        updata(x,y,d,1,n,1);
        }
        getchar();
    }
    return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值