Doing Homework again

Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.

Input

The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow. 
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores. 

Output

For each test case, you should output the smallest total reduced score, one line per test case. 

Sample Input

3
3
3 3 3
10 5 1
3
1 3 1
6 2 3
7
1 4 6 4 2 4 3
3 2 1 7 6 5 4

Sample Output

0
3
5

思路:这道题先按分数从高道题排序,如果分数相同就按日期排序,从截止日期往前推,如果其中有一天没有用过,则这一天做第i份作业并标记,比如j=4,则从第四天开始往前推,找到四天中最晚的空的时间,来做这份作业。,如果这份作业在截止日期前没有时间做,则这没课完不成。

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
struct node
{
    int a,b;
}sll[1010];
bool cmp(node x,node y)
{
    if(x.b!=y.b)
        return x.b>y.b;
    return x.a<y.a;
}
int main()
{
    int t,c[1010];
    scanf("%d",&t);
    while(t--)
    {
        int n,m,sum=0,i;
        memset(c,0,sizeof(c));
        scanf("%d",&n);
        for(i=0;i<n;i++)
            scanf("%d",&sll[i].a);
        for(i=0;i<n;i++)
            scanf("%d",&sll[i].b);
        sort(sll,sll+n,cmp);//排序
        for(i=0;i<n;i++)
        {
            m=sll[i].a;
            while(m)//从截止日期开始
            {
                if(c[m]==0)
                {
                    c[m]=1;break;//标记
                }
                m--;
            }
            if(m==0)//没法完成任务
                sum+=sll[i].b;
        }
        printf("%d\n",sum);
    }
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值