acm steps 2.1.3

Largest prime factor

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 4525    Accepted Submission(s): 1360


 

Problem Description

Everybody knows any number can be combined by the prime number.
Now, your task is telling me what position of the largest prime factor.
The position of prime 2 is 1, prime 3 is 2, and prime 5 is 3, etc.
Specially, LPF(1) = 0.

 


 

Input

Each line will contain one integer n(0 < n < 1000000).

 


 

Output

Output the LPF(n).

 


 

Sample Input

1 2 3 4 5

 


 

Sample Output

0 1 2 1 3

开始想用筛法把素数全部列出来挨个试,果断超时了,后来改进了下,直接打表,但是还是超时,结果把输入输出换成c的方式就好了。。。

#include<iostream>
#include<string>
#include<cstring>
#include<iomanip>
#include<cstdio>
#include<algorithm>
#include<vector>
#include<cmath>
using namespace std;
typedef long long ll;
typedef vector<int> vi;
const int N=1000000;
int a[N+1]={0};
int main()
{
   int cont=0;
   for(int i=2;i<=N;i++)
   {
       if(0==a[i]){
            cont++;
            a[i]=cont;
       for(int j=2;j*i<N;j++)
       {
           a[j*i]=cont;
       }
       }
   }
   int x;

   while(scanf("%d",&x)!=EOF)
 {
  printf("%d\n",a[x]);
 }


 /*while(cin>>x)
   {
       if(1==x)
        cout<<0<<endl;
       else
        cout<<a[x]<<endl;///就是这里超时了。。c++和c的效率差异真是令人震惊啊,用c++写超时(1000ms),用c写是281ms,把scanf留着把printf换成cout还是超时,差距咋能这么大?。。。。。
   }*/
   return 0;
}

 

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值