ACM: 变形的最大公共自序列 动态规…

                                                                          Human Gene Functions
Description
It is well known that a human gene can be considered as a sequence, consisting of four nucleotides, which are simply denoted by four letters, A, C, G, and T. Biologists have been interested in identifying human genes and determining their functions, because these can be used to diagnose human diseases and to design new drugs for them.

A human gene can be identified through a series of time-consuming biological experiments, often with the help of computer programs. Once a sequence of a gene is obtained, the next job is to determine its function.
One of the methods for biologists to use in determining the function of a new gene sequence that they have just identified is to search a database with the new gene as a query. The database to be searched stores many gene sequences and their functions – many researchers have been submitting their genes and functions to the database and the database is freely accessible through the Internet.

A database search will return a list of gene sequences from the database that are similar to the query gene.
Biologists assume that sequence similarity often implies functional similarity. So, the function of the new gene might be one of the functions that the genes from the list have. To exactly determine which one is the right one another series of biological experiments will be needed.

Your job is to make a program that compares two genes and determines their similarity as explained below. Your program may be used as a part of the database search if you can provide an efficient one.
Given two genes AGTGATG and GTTAG, how similar are they? One of the methods to measure the similarity
of two genes is called alignment. In an alignment, spaces are inserted, if necessary, in appropriate positions of
the genes to make them equally long and score the resulting genes according to a scoring matrix.

For example, one space is inserted into AGTGATG to result in AGTGAT-G, and three spaces are inserted into GTTAG to result in –GT--TAG. A space is denoted by a minus sign (-). The two genes are now of equal
length. These two strings are aligned:

AGTGAT-G
-GT--TAG

In this alignment, there are four matches, namely, G in the second position, T in the third, T in the sixth, and G in the eighth. Each pair of aligned characters is assigned a score according to the following scoring matrix.
ACM: <wbr>变形的最大公共自序列 <wbr>动态规划 <wbr>poj <wbr>1080

denotes that a space-space match is not allowed. The score of the alignment above is (-3)+5+5+(-2)+(-3)+5+(-3)+5=9.

Of course, many other alignments are possible. One is shown below (a different number of spaces are inserted into different positions):

AGTGATG
-GTTA-G

This alignment gives a score of (-3)+5+5+(-2)+5+(-1) +5=14. So, this one is better than the previous one. As a matter of fact, this one is optimal since no other alignment can have a higher score. So, it is said that the
similarity of the two genes is 14.

Input

The input consists of T test cases. The number of test cases ) (T is given in the first line of the input file. Each test case consists of two lines: each line contains an integer, the length of a gene, followed by a gene sequence. The length of each gene sequence is at least one and does not exceed 100.

Output

The output should print the similarity of each test case, one per line.

Sample Input

2 
7 AGTGATG
5 GTTAG
7 AGCTATT
9 AGCTTTAAA

Sample Output

14

21

题意: 两段基因序列, 如果匹配出来的分数就是相识程度, 越大的分数表示越相似, 现在要你求出最大分数的
     对齐方式的分数.

解题思路:
       1. 状态: dp[i][j]: 表示第一串中前i个与第二串中前j个配对的最大分数.
       2. 状态转移方程: dp[i][j] = max(
                              dp[i-1][j-1]+score[i-1][j-1], //不加空格的配对分数
                              dp[i-1][j]+score[i-1]['-'], //第二串j位置加空格
                              dp[i][j-1]+score['-'][j-1]); //第一串i位置加空格

代码:
#include <cstdio>
#include <iostream>
#include <cstring>
using namespace std;
#define MAX 105

int n, m;
char str1[MAX], str2[MAX];
int dp[MAX][MAX];

int score[5][5] = { {5,-1,-2,-1,-3} , {-1,5,-3,-2,-4} ,
        {-2,-3,5,-2,-2} , {-1,-2,-2,5,-1}, {-3,-4,-2,-1,-MAX}};

int getnum(char ch)
{
    if(ch == 'A') return 0;
    else if(ch == 'C') return 1;
    else if(ch == 'G') return 2;
    else if(ch == 'T') return 3;
    else if(ch == '-') return 4;
}

inline int max(int a,int b)
{
    return a > b ? a : b;
}

int main()
{
//    freopen("input.txt","r",stdin);
    int caseNum;
    scanf("%d",&caseNum);
    while(caseNum--)
    {
        scanf("%d %s",&n,str1);
        scanf("%d %s",&m,str2);
        memset(dp,0,sizeof(dp));
       
        for(int i = 1; i <= n; ++i)
            dp[0][i] = dp[0][i-1] + score[ getnum(str2[i-1]) ][ getnum('-') ];
        for(int i = 1; i <= m; ++i)
            dp[i][0] = dp[i-1][0] + score[ getnum(str1[i-1]) ][ getnum('-') ];
           
        for(int i = 1; i <= n; ++i)
        {
            for(int j = 1; j <= m; ++j)
            {
                dp[i][j] = max( dp[i-1][j-1]+score[ getnum(str1[i-1]) ][ getnum(str2[j-1]) ] ,
                max( dp[i-1][j]+score[ getnum(str1[i-1]) ][ getnum('-') ] ,
                dp[i][j-1]+score[ getnum('-') ][ getnum(str2[j-1]) ] ) );
            }
        }
        printf("%d\n",dp[n][m]);
    }
    return 0;
}
 
严谨些代码:
#include <cstdio>
#include <iostream>
#include <cstring>
using namespace std;
#define MAX 105
const int INF = (1<<29);
int score[5][5] = { {5,-1,-2,-1,-3},
     {-1,5,-3,-2,-4},
     {-2,-3,5,-2,-2},
     {-1,-2,-2,5,-1},
     {-3,-4,-2,-1,-MAX}
    };
int n, m;
char str1[MAX], str2[MAX];
int a[MAX], b[MAX];
int dp[MAX][MAX];
inline int getNum(char ch)
{
 if(ch == 'A') return 0;
 else if(ch == 'C') return 1;
 else if(ch == 'G') return 2;
 else if(ch == 'T') return 3;
 else if(ch == '-') return 4;
 else return 5;
}
inline int max(int a,int b)
{
 return a > b ? a : b;
}
int main()
{
 int i, j;
 int caseNum;
// freopen("input.txt","r",stdin);
 scanf("%d",&caseNum);
 while(caseNum--)
 {
  cin >> n >> str1+1 >> m >> str2+1;
  memset(dp,0,sizeof(dp));
  for(i = 1; i <= n; ++i)
   a[i] = getNum(str1[i]);
  for(j = 1; j <= m; ++j)
   b[j] = getNum(str2[j]);
  for(i = 0; i <= n; ++i)
  {
   for(j = 0; j <= m; ++j)
   {
    if(i == 0 && j == 0) dp[i][j] = 0;
    else if(i > 0 && j == 0) dp[i][j] = dp[i-1][j] + score[ a[i] ][4];
    else if(i == 0 && j > 0) dp[i][j] = dp[i][j-1] + score[4][ b[j] ];
    else
     dp[i][j] = max(dp[i-1][j-1]+score[a[i]][b[j]] , max(dp[i-1][j]+score[a[i]][4], dp[i][j-1]+score[4][b[j]]) );
   }
  }

  printf("%d\n",dp[n][m]);
 }
 return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值