POJ 2251 Dungeon Master(广搜)

Description

You are trapped in a 3D dungeon and need to find the quickest way out! The dungeon is composed of unit cubes which may or may not be filled with rock. It takes one minute to move one unit north, south, east, west, up or down. You cannot move diagonally and the maze is surrounded by solid rock on all sides.

Is an escape possible? If yes, how long will it take?
Input

The input consists of a number of dungeons. Each dungeon description starts with a line containing three integers L, R and C (all limited to 30 in size).
L is the number of levels making up the dungeon.
R and C are the number of rows and columns making up the plan of each level.
Then there will follow L blocks of R lines each containing C characters. Each character describes one cell of the dungeon. A cell full of rock is indicated by a ‘#’ and empty cells are represented by a ‘.’. Your starting position is indicated by ‘S’ and the exit by the letter ‘E’. There’s a single blank line after each level. Input is terminated by three zeroes for L, R and C.
Output

Each maze generates one line of output. If it is possible to reach the exit, print a line of the form
Escaped in x minute(s).

where x is replaced by the shortest time it takes to escape.
If it is not possible to escape, print the line
Trapped!
Sample Input

3 4 5
S….
.###.
.##..
###.#

#####
#####
##.##
##…

#####
#####
#.###
####E

1 3 3
S##
#E#
###

0 0 0
Sample Output

Escaped in 11 minute(s).
Trapped!

题目概述
水题啊我也这么觉得,就是把二维的思想换成三维的,我也是敲完没有调试数据直接就过了,可是跪了MLE一条街,昨天晚上改了好久一直不对,早上又拿出来第一次MLE的代码改了一下提交竟然就过了。持续懵逼(⊙﹏⊙)安葬下拙劣的代码(o´・ェ・`o)

代码实现

#include <iostream>
#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;
char maps[36][36][36];
bool visit[36][36][36],flag;
int dire[6][3]= {{1,0,0},{-1,0,0},{0,1,0},{0,-1,0},{0,0,1},{0,0,-1}};
int l,r,c;
struct node
{
    int x;
    int y;
    int z;
    int step;
} s;
void BFS()
{
    node temp,ne;
    s.step=0;
    queue<node>qu;
    qu.push(s);
    while(!qu.empty())
    {
        temp=qu.front();
        visit[temp.x][temp.y][temp.z]=1;
        qu.pop();
        for(int i=0; i<6; i++)
        {
            ne.x=temp.x+dire[i][0];
            ne.y=temp.y+dire[i][1];
            ne.z=temp.z+dire[i][2];
            ne.step=temp.step+1;
            if(ne.x>0&&ne.x<=l&&ne.y>0&&ne.y<=r&&ne.z>0&&ne.z<=c&&!visit[ne.x][ne.y][ne.z])
            {
                if(maps[ne.x][ne.y][ne.z]=='E')
                {
                    printf("Escaped in %d minute(s).\n",ne.step);
                    flag=true;
                    return ;
                }
                else
                {
                    visit[ne.x][ne.y][ne.z]=1;
                    qu.push(ne);
                }
            }
        }
    }
}
int main()
{
    while(~scanf("%d %d %d%*c",&l,&r,&c))
    {
        flag=false;
        memset(visit,0,sizeof(visit));
        if(l==0&&r==0&&c==0) break;
        for(int i=1; i<=l; i++)
        {
            for(int j=1; j<=r; j++)
            {
                for(int k=1; k<=c; k++)
                {
                    scanf("%c",&maps[i][j][k]);
                    if(maps[i][j][k]=='S')
                    {
                        s.x=i,s.y=j,s.z=k;
                        visit[i][j][k]=1;
                    }
                    if(maps[i][j][k]=='#')
                        visit[i][j][k]=1;
                }
                getchar();
            }
            getchar();
        }
        BFS();
        if(!flag)
            printf("Trapped!\n");
    }
    return 0;
}

接着是明知会超时还是固执的去敲完的DFS()。我不闲( ⊙ o ⊙ )啊!

#include <iostream>
#include<cstdio>
#include<cstring>
using namespace std;
char maps[36][36][36];
bool visit[36][36][36];
int dire[6][3]= {{1,0,0},{-1,0,0},{0,1,0},{0,-1,0},{0,0,1},{0,0,-1}};
int ans,l,r,c;
struct node
{
    int x;
    int y;
    int z;
} s,e;
void DFS(node temp,int t)
{
    node ne;
    if(t>ans)
        return;
    if(maps[temp.x][temp.y][temp.z]=='E')
    {
        ans=min(ans,t);
        return ;
    }
    for(int i=0; i<6; i++)
    {
        ne.x=temp.x+dire[i][0];
        ne.y=temp.y+dire[i][1];
        ne.z=temp.z+dire[i][2];
        if(ne.x<=0||ne.x>l||ne.y<=0||ne.y>r||ne.z<=0||ne.z>c||visit[ne.x][ne.y][ne.z])
            continue;
        visit[ne.x][ne.y][ne.z]=1;
        DFS(ne,t+1);
        visit[ne.x][ne.y][ne.z]=0;
    }
}
int main()
{
    while(~scanf("%d %d %d%*c",&l,&r,&c))
    {
        ans=30000;
        memset(visit,0,sizeof(visit));
        if(l==0&&r==0&&c==0) break;
        for(int i=1; i<=l; i++)
        {
            for(int j=1; j<=r; j++)
            {
                for(int k=1; k<=c; k++)
                {
                    scanf("%c",&maps[i][j][k]);
                    if(maps[i][j][k]=='S')
                        s.x=i,s.y=j,s.z=k;
                    if(maps[i][j][k]=='#')
                        visit[i][j][k]=1;
                }
                getchar();
            }
            getchar();
        }
        DFS(s,0);
        if(ans==30000)
            printf("Trapped!\n");
        else
            printf("Escaped in %d minute(s).\n",ans);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值