POJ3259-Wormholes 虫洞

说白了就是找负回路,利用虫洞尝试看到从前的自己

filed是双向的路径 但是wormhole是单向的负路径



Wormholes
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 22684 Accepted: 8085

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..NM (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer,  FF farm descriptions follow. 
Line 1 of each farm: Three space-separated integers respectively:  NM, and  W 
Lines 2.. M+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: a bidirectional path between  S and  E that requires  T seconds to traverse. Two fields might be connected by more than one path. 
Lines  M+2.. M+ W+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: A one way path from  S to  E that also moves the traveler back  T seconds.

Output

Lines 1.. F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time. 
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.





//time 250ms memory 300k

#include<iostream>
using namespace std;


int dis[1001];//即D[k][u]=dis[u] k逐步relax提高
const int MAX=100000;
class weight{
public:
int s;
int e;
int t;
}edge[6000];


int N,M,W;
int all_e;




bool bellman()
{
bool flag;


for(int k=1;k<=N-1;k++)
{
flag=0;
for(int i=0;i<all_e;i++)
{
if(dis[ edge[i].e] > dis[edge[i].s ] + edge[i].t )
{
dis[edge[i].e] = dis[edge[i].s ] + edge[i].t;
flag=1;//关键!原先的距离大于 j边上加edge的举例
}
}
if(!flag)
break;
}
//查找负环 对每条边进行检测 如果发现可继续更新的边即存在负环
for(int i=0;i<all_e;i++)
if(dis[ edge[i].e ] > dis[ edge[i].s ] + edge[i].t )
return 1;//有负环


return 0;//找不到负环
}
int main()
{
int u,v,w,F;
cin>>F;
while(F--)
{
memset(dis,MAX,sizeof(dis) );//默认设置dis最大
cin>>N>>M>>W;
all_e=0;//所有边数记0
//输入开始
for(int i=1;i<=M;i++)
{
cin>>u>>v>>w;
edge[all_e].s=edge[all_e+1].e=u;
edge[all_e].e=edge[all_e+1].s=v;
edge[all_e].t=edge[all_e+1].t=w;//双向性
all_e+=2;//指针滚动
}
for(int i=1;i<=W;i++)
{
cin>>u>>v>>w;
edge[all_e].s=u;
edge[all_e].e=v;
edge[all_e].t=-w;//双向性
all_e++;//指针滚动
}
//bellman-ford开始
if(bellman())
cout<<"YES"<<endl;
else
cout<<"NO"<<endl;




}//while F
return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值