hdu 1875 hdoj 1875

畅通工程再续

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5382    Accepted Submission(s): 1595


Problem Description
相信大家都听说一个“百岛湖”的地方吧,百岛湖的居民生活在不同的小岛中,当他们想去其他的小岛时都要通过划小船来实现。现在政府决定大力发展百岛湖,发展首先要解决的问题当然是交通问题,政府决定实现百岛湖的全畅通!经过考察小组RPRush对百岛湖的情况充分了解后,决定在符合条件的小岛间建上桥,所谓符合条件,就是2个小岛之间的距离不能小于10米,也不能大于1000米。当然,为了节省资金,只要求实现任意2个小岛之间有路通即可。其中桥的价格为 100元/米。
 

Input
输入包括多组数据。输入首先包括一个整数T(T <= 200),代表有T组数据。
每组数据首先是一个整数C(C <= 100),代表小岛的个数,接下来是C组坐标,代表每个小岛的坐标,这些坐标都是 0 <= x, y <= 1000的整数。
 

Output
每组输入数据输出一行,代表建桥的最小花费,结果保留一位小数。如果无法实现工程以达到全部畅通,输出”oh!”.
 

Sample Input
  
  
2 2 10 10 20 20 3 1 1 2 2 1000 1000
 

Sample Output
  
  
1414.2 oh!


#include<stdio.h>
#include<stdlib.h>
#include<math.h>

int father[103];

typedef struct Island{
    int x;
    int y;
    double cost;
}Island;

int compare(const void *a,const void *b){
    if((*(Island*)a).cost>(*(Island*)b).cost) return 1;
    else if((*(Island*)a).cost<(*(Island*)b).cost) return -1;
    else return 0;
}

Island land[5051];

int find(int x){
    if(x!=father[x]){
        find(father[x]);
    }
    else return x;
}

void unionset(int x,int y){
    int a=find(x),b=find(y);
    if(a<b) father[b]=a;
    else father[a]=b;
}

int main(){
    int t,c,i,num,count,j;
    double cost;
    int maze[103][2];
    scanf("%d",&t);
    while(t--){
        for(i=0;i<103;i++){
            father[i]=i;
        }
        count=0,cost=0,num=0;
        scanf("%d",&c);
        for(i=0;i<c;i++){
            scanf("%d%d",&maze[i][0],&maze[i][1]);
        }
        for(i=0;i<c;i++){
            for(j=i+1;j<c;j++){
                double dist=sqrt(1.0*(maze[i][0]-maze[j][0])*(maze[i][0]-maze[j][0])+(maze[i][1]-maze[j][1])*(maze[i][1]-maze[j][1]));
                if(dist>=10&&dist<=1000){
                    land[num].x=i;
                    land[num].y=j;
                    land[num].cost=dist;
                    num++;
                }
            }
        }
        if(num<c-1){
            printf("oh!\n");
            continue;
        }
        qsort(land,num,sizeof(Island),compare);
        for(i=0;i<num;i++){
            if(find(land[i].x)!=find(land[i].y)){
                unionset(land[i].x,land[i].y);
                cost+=land[i].cost;
                count++;
            }
            if(count==c-1) break;
        }
        if(count==c-1) printf("%.1lf\n",cost*100);
        else printf("oh!\n");
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值