使用Maven创建项目出现Java compiler level does not match the version of the installed Java project facet解决

steps1:
查看开发工具编译java版本:
这里写图片描述
图片中可以看到java版本是1.8
step2:
在项目文件夹中:
打开项目->打开.settings—>编辑org.eclipse.wst.common.project.facet.core.xml
修改java版本:
一般在第三行

<?xml version="1.0" encoding="UTF-8"?>
<faceted-project>
  <fixed facet="wst.jsdt.web"/>
  <installed facet="java" version="1.8"/>
  <installed facet="jst.web" version="2.3"/>
  <installed facet="wst.jsdt.web" version="1.0"/>
</faceted-project>

此处java版本是1.8

阅读更多
版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/songguangnuan/article/details/70336092
文章标签: maven
个人分类: maven
想对作者说点什么? 我来说一句

没有更多推荐了,返回首页

不良信息举报

使用Maven创建项目出现Java compiler level does not match the version of the installed Java project facet解决

最多只允许输入30个字

加入CSDN,享受更精准的内容推荐,与500万程序员共同成长!
关闭
关闭