最小生成树 - H - Highways

Highways

Description

The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has a very poor system of public highways. The Flatopian government is aware of this problem and has already constructed a number of highways connecting some of the most important towns. However, there are still some towns that you can't reach via a highway. It is necessary to build more highways so that it will be possible to drive between any pair of towns without leaving the highway system. 

Flatopian towns are numbered from 1 to N and town i has a position given by the Cartesian coordinates (xi, yi). Each highway connects exaclty two towns. All highways (both the original ones and the ones that are to be built) follow straight lines, and thus their length is equal to Cartesian distance between towns. All highways can be used in both directions. Highways can freely cross each other, but a driver can only switch between highways at a town that is located at the end of both highways. 

The Flatopian government wants to minimize the cost of building new highways. However, they want to guarantee that every town is highway-reachable from every other town. Since Flatopia is so flat, the cost of a highway is always proportional to its length. Thus, the least expensive highway system will be the one that minimizes the total highways length. 

Input

The input consists of two parts. The first part describes all towns in the country, and the second part describes all of the highways that have already been built. 

The first line of the input file contains a single integer N (1 <= N <= 750), representing the number of towns. The next N lines each contain two integers, xi and yi separated by a space. These values give the coordinates of i th town (for i from 1 to N). Coordinates will have an absolute value no greater than 10000. Every town has a unique location. 

The next line contains a single integer M (0 <= M <= 1000), representing the number of existing highways. The next M lines each contain a pair of integers separated by a space. These two integers give a pair of town numbers which are already connected by a highway. Each pair of towns is connected by at most one highway. 

Output

Write to the output a single line for each new highway that should be built in order to connect all towns with minimal possible total length of new highways. Each highway should be presented by printing town numbers that this highway connects, separated by a space. 

If no new highways need to be built (all towns are already connected), then the output file should be created but it should be empty. 

Sample Input

9
1 5
0 0 
3 2
4 5
5 1
0 4
5 2
1 2
5 3
3
1 3
9 7
1 2

Sample Output

1 6
3 7
4 9
5 7
8 3
题意:给定N个地方的坐标,需要用路将其都连接起来,一些地方已经连接了起来,问还需要连接哪些路,打印路径。
题解:裸prim模板题,唯一注意在比较时需要用double类型,int会WA掉。
AC代码:
#include<iostream>
#include<cmath>
using namespace std;
int n,m;
const int maxn = 800;
const int inf = 0x3f3f3f3f;
double a[maxn][maxn];
int x[maxn],y[maxn];
int path[maxn];
int vis[maxn];
double length[maxn];
double leng(double x1,double y1,double x2,double y2)
{
    return sqrt((x1-x2)*(x1-x2)+(y1-y2)*(y1-y2));
}
void prim()
{
    for(int i=1;i<=n;i++)
    {
        length[i]=a[1][i];
        vis[i]=0;
        path[i]=1;
    }
    for(int i=1;i<=n;i++)
    {
        double mi = inf;
        int u;
        for(int j=1;j<=n;j++)
        {
            if(vis[j]==0&&mi>length[j])
            {
                mi=length[j];
                u=j;
            }
        }
        vis[u]=1;
       
        for(int j=1;j<=n;j++)
        {
            if(vis[j]==0&&length[j]>a[u][j])
            {
                length[j]=a[u][j];
                path[j]=u;
            }
        }
        if(a[u][path[u]]==0)continue;
        else cout<<path[u]<<" "<<u<<endl;
    }
}
int main()
{
    while(cin>>n)
    {
        for(int i=1;i<=n;i++)cin>>x[i]>>y[i];
        for(int i=1;i<=n;i++)
            for(int j=i;j<=n;j++)
            a[i][j]=a[j][i]=leng(x[i],y[i],x[j],y[j]);
        cin>>m;
        for(int j=1;j<=m;j++)
        {
            int g,k;
            cin>>g>>k;
            a[g][k]=a[k][g]=0;
        }
        prim();
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值