交换机简单配置


说明

介绍一些网络相关知识,慢慢积累,慢慢成长。
这是我一次简单配置交换机的经历。


交换机简介

交换机是二层网络设备,作用是寻址和转发,
先寻找对应设备的mac地址,再根据mac地址进行转发数据帧。

那么是如何寻址的呢?

交换机内部都有记录MAC地址的转发表,每个设
备的MAC地址对应一个端口,转发表就是记录端口和MAC地址映射关系的表。转发表是通过广播学习生成的。


端口类型

trunk口、access口 (hybird口暂时不做介绍)

access口只支持一个VLAN,收到以太网帧打上VLAN标签,转发时剥离VLAN标签

trunk和hybir支持多个VLAN,可以接收转发多个VLAN的数据


记录一次实际配置(以H3C交换机为例)

配置trunk口和VLAN

//用户视图
<H3C>
//进入系统视图
<H3C>system-view        //进入配置视图
[H3C]


//添加VLAN
//创建VLAN 20 和 VLAN 30
[H3C] vlan 20 
[H3C-vlan10] quit 
[H3C] vlan 30 
[H3C-vlan10] quit 


//配置VLAN  的IP地址  
[H3C] interface Vlan-interface20 
[H3C-Vlan-interface10] ip address 20.0.0.254 255.255.255.0 
[H3C] interface Vlan-interface30 
[H3C-Vlan-interface10] ip address 30.0.0.254 255.255.255.0


//端口 GigabitEthernet1/0/1 的配置
//进入端口 g1/0/1
[H3C] interface GigabitEthernet1/0/1 
//配置为trunk口
[H3C- GigabitEthernet1/0/1] port link-type trunk   
[H3C- GigabitEthernet1/0/1] port trunk vlan 20  
[H3C- GigabitEthernet1/0/1] port trunk vlan 30  
//设置trunk口允许通过的VLAN 
[H3C- GigabitEthernet1/0/1] port trunk permit vlan 20
[H3C- GigabitEthernet1/0/1] port trunk permit vlan 30
//设置允许所有通过 port trunk permit vlan all
[H3C- GigabitEthernet1/0/1] quit

//端口 GigabitEthernet1/0/2
[H3C] interface GigabitEthernet1/0/2
//配置为access口
[H3C- GigabitEthernet1/0/2] port link-type access  
[H3C- GigabitEthernet1/0/2] port access vlan 20   
[H3C- GigabitEthernet1/0/2] quit

//端口 GigabitEthernet1/0/3
[H3C] interface GigabitEthernet1/0/3
//配置为access口
[H3C- GigabitEthernet1/0/3] port link-type access  
[H3C- GigabitEthernet1/0/3] port access vlan 30
[H3C- GigabitEthernet1/0/3] quit

配置聚合端口

//创建聚合组
[H3C] interface bridge-aggregation 1

//端口 GigabitEthernet1/0/5
[H3C] interface GigabitEthernet1/0/5
//配置为trunk口
[H3C- GigabitEthernet1/0/5] port link-type trunk
[H3C- GigabitEthernet1/0/5] port trunk permit vlan all
//下面这步最后执行
[H3C- GigabitEthernet1/0/5] port link-aggregation group 1
[H3C- GigabitEthernet1/0/5] quit

可以试试下面这种方式
[SwitchA] interface bridge-aggregation 1
[SwitchA-Bridge-Aggregation1] port link-type trunk
[SwitchA-Bridge-Aggregation1] port trunk permit vlan 10 20
[SwitchA-Bridge-Aggregation1] quit

查看交换机配置

//查看当前配置信息
display current-configuration

//查看某个端口信息
//查看端口 GigabitEthernet1/0/1  的配置信息
display current-configuration interface g1/0/1


在这里插入图片描述

欢迎大家关注我,了解更多网络知识!

相关推荐
©️2020 CSDN 皮肤主题: 游动-白 设计师:白松林 返回首页