D-City HDU - 4496(反向并查集)

Luxer is a really bad guy. He destroys everything he met.
One day Luxer went to D-city. D-city has N D-points and M D-lines. Each D-line connects exactly two D-points. Luxer will destroy all the D-lines. The mayor of D-city wants to know how many connected blocks of D-city left after Luxer destroying the first K D-lines in the input.
Two points are in the same connected blocks if and only if they connect to each other directly or indirectly.
Input
First line of the input contains two integers N and M.
Then following M lines each containing 2 space-separated integers u and v, which denotes an D-line.
Constraints:
0 < N <= 10000
0 < M <= 100000
0 <= u, v < N.
Output
Output M lines, the ith line is the answer after deleting the first i edges in the input.
Sample Input
5 10
0 1
1 2
1 3
1 4
0 2
2 3
0 4
0 3
3 4
2 4
Sample Output
1
1
1
2
2
2
2
3
4
5

Hint
The graph given in sample input is a complete graph, that each pair of vertex has an edge connecting them, so there’s only 1 connected block at first.
The first 3 lines of output are 1s because after deleting the first 3 edges of the graph, all vertexes still connected together.
But after deleting the first 4 edges of the graph, vertex 1 will be disconnected with other vertex, and it became an independent connected block.
Continue deleting edges the disconnected blocks increased and finally it will became the number of vertex, so the last output should always be N.
给你一张图,问删除前i条边时的联通个数是多少?
答案肯定是非递减序列,而且最后的答案肯定是n。我们知道,一开始的所有的点没有边时,也是n个连通块(每个点都是一个连通块)。连上最后一条边,连通块减一。这样我们倒着去找,思路就很清楚了,就是看连上这条边之后,连通块个数变为多少。
代码如下:

#pragma comment(linker, "/STACK:102400000,102400000")//这一块可以不用,一开始数组开小了
#include<bits/stdc++.h>
#define ll long long
using namespace std;

const int maxx=1e4+100;
const int maxm=1e6+100;
struct node{
	int x,y;
}p[maxm];
int f[maxx],ans[maxm],size[maxx];
int n,m,sum;

inline int find(int u)
{
	if(u==f[u]) return u;
	else return f[u]=find(f[u]);
}
inline int merge(int u,int v)
{
	int t1=find(u);
	int t2=find(v);
	if(t1!=t2)
	{
		sum--;
		if(size[t1]<size[t2]) f[t1]=t2;//按照规模大小,小的往大的合并。
		else f[t2]=t1;
		return 1;
	}
	return 0;
}
int main()
{
	int x,y;
	while(~scanf("%d%d",&n,&m))
	{
		for(int i=0;i<=n;i++) f[i]=i,size[i]=1;
		for(int i=1;i<=m;i++) scanf("%d%d",&p[i].x,&p[i].y);
		sum=n;
		for(int i=m;i>=1;i--)
		{
			x=p[i].x,y=p[i].y;
			if(merge(x,y)) ans[i]=sum+1;
			else ans[i]=sum;
		}
		for(int i=1;i<=m;i++) printf("%d\n",ans[i]);
	}
	return 0;
}

努力加油a啊,(o)/~

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

starlet_kiss

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值