eclipse3.3 安装 jseclipse插件用于编辑javascript

  最近真的是变懒了,以前都是用patch方法来安装eclipse插件的,现在则直接用在线update来更新了。
    网上有一篇广为流传的在线安装jseclipse的文章,但是在那个地址下安装的jseclipse是1.5.3版本,不支持最新的eclipse3..3,我在网上找到另一个文章( http://www.cl.ci.i.u-tokyo.ac.jp/~zhou/EclipseTips.html),才知道了是这个原因。
    安装方法很简单:
 1. [Help]-[Software Updates]-[Find and Install...]

2. [Search for new features to install] -> [Next]

3. [New Remote Site...]

Name: "什么都行,比如JSEclipse from Adobe Labs"

URL: http://download.macromedia.com/pub/labs/jseclipse/autoinstall

--> [Finish]

4. 选择 JSEclipse,[Next],然后按照指示作即可。

这里的地址和网上的不同的是网上的地址是“http://www.interaktonline.com/”,这个只能到1.5.3



然后安装jseclipse对ext的支持。

到JS堂的“http://jstang.5d6d.com/thread-102-1-1.html”下载神话缔造者制作的库文件,然后放到

“[工作目录]/.metadata/.plugins/com.interaktonline.jseclipse/user_library”下,重启eclipse即可。

如果重启后还是没有ext的自动提示,那么启动eclipse的快捷方式里加上“ -clean”参数就可以了。

ext是好东西,如果有可视化开发工具就爽了~
今天把最近在工作中研究的内容发表出来,不知道以前有没有前辈这么干过,不过,我全都是自己摸索出来的,当然,google也帮了大忙,最近研究的内容 ext以前没有接触过UI组件的内容,所以压力比较大啊,呵呵,不过,已经到了峰回路转,柳暗花明的境地,开始研究ext的核心代码了。

 

        下面说一下如何在eclipse下进行ext的开发工作。

        第一:eclipse环境建立(基于项目组目前的环境设置)
        第二:下载jsEclipse: http://www.adobe.com/cfusion/entitlement/index.cfm?e=labs_jseclipse  (需要注册)
        第三:配置文件关联方式: window-preference---general-editors:file association,找到*.js,将jseclipse设为default。
        第四:打开任意一个js文件(为了出现JSEclipse菜单),在JSEclipse菜单下,选择Add Library,导航到ext-all-debug.js,引入该库,然后在菜单下:refresh code completion library即可,这将会在D:/workspace/.metadata/.plugins/ com.interaktonline.jseclipse/library/YourProject下生成插件xml文档。

 

        如此设置后,你在js文件中将会得到智能感知和自动完成的功能了,包括js固有的对象,还有第四步我们引入的ext库。
 
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值