sdut_2132_数据结构实验之栈与队列二:一般算术表达式转换成后缀式

数据结构实验之栈与队列二:一般算术表达式转换成后缀式

Time Limit: 1000 ms Memory Limit: 65536 KiB

Submit Statistic Discuss

Problem Description

对于一个基于二元运算符的算术表达式,转换为对应的后缀式,并输出之。

Input

输入一个算术表达式,以‘#’字符作为结束标志。

Output

输出该表达式转换所得到的后缀式。

Sample Input

a*b+(c-d/e)*f#

Sample Output

ab*cde/-f*+

Hint

Source

 

 

输入字符  - >   如果字符为小写字母,输出 - > 如果字符为运算符号,判断优先级,如果 当前运算符号优先级大于栈顶优先级 则压栈, 否则输出栈顶直至top= 0或者栈顶优先级小于当前运算符号(当栈顶为‘(’时当前运算符号直接压栈) - > 如果当前字符为‘)’时 则输出栈顶 直到栈顶为‘(’ ->  如果栈中还存有字符 那么输出。

代码如下:

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <math.h>

char s[100005];
int main()
{
    char st;
    int top = 0;
    while(scanf("%c", &st))
    {
        if(st == '#')
            break;
        else if(st >= 'a' && st <= 'z')
            printf("%c", st);
        else if(st == '(')
            s[++top] = st;
        else if(st == '+' || st == '-')
        {
            while(1)
            {
                if(top == 0 || s[top] == '(')
                {
                    s[++top] = st;
                    break;
                }
                printf("%c", s[top]);
                top--;
            }
        }
        else if(st == '*' || st == '/')
        {
            while(1)
            {
                if(top == 0 || s[top] == '+' || s[top] == '-' || s[top] == '(')
                {
                    s[++top] = st;
                    break;
                }
                printf("%c", s[top--]);
            }
        }
        else if(st == ')')
        {
            for(;s[top] != '('; top--)
            {
                printf("%c", s[top]);
            }
            top--;
        }
    }
    for(; top > 0; top--)
            printf("%c", s[top]);
    return 0;
}
 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值