1046. Shortest Distance (20)

1046. Shortest Distance (20)

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

Input Specification:

Each input file contains one test case. For each case, the first line contains an integer N (in [3, 105]), followed by N integer distances D1 D2 … DN, where Di is the distance between the i-th and the (i+1)-st exits, and DN is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (<=104), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 107.

Output Specification:

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

Sample Input:

5 1 2 4 14 9
3
1 3
2 5
4 1

Sample Output:

3
10
7


#include<iostream>
#include<cmath>
#define MAXN 100005 
using namespace std;
int main()
{
    int n,m,a,b;
    int d1,d2,sum=0;
    int dis[MAXN],mp[MAXN];
    cin>>n;
    mp[0]=0;
    for(int i=1;i<=n;i++)//计算机总和 
    {
        cin>>dis[i];
        sum+=dis[i];
        mp[i]=sum;//记录距离,不然会超时 
    }
    cin>>m;
    for(int i=0;i<m;i++)
    {
        d1=0;
        d2=sum;
        cin>>a>>b;
        if(a>b)//交换节点 
        {
            int temp=b; b=a; a=temp;
        }
        int k=mp[b-1]-mp[a-1];
        cout<<min(k,sum-k)<<endl;
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值