Ants -暴力枚举

8 篇文章 0 订阅

     Ants

An army of ants walk on a horizontal pole of length l cm, each with a constant speed of 1 cm/s. When a walking ant reaches an end of the pole, it immediatelly falls off it. When two ants meet they turn back and start walking in opposite directions. We know the original positions of ants on the pole, unfortunately, we do not know the directions in which the ants are walking. Your task is to compute the earliest and the latest possible times needed for all ants to fall off the pole.
Input
The first line of input contains one integer giving the number of cases that follow. The data for each case start with two integer numbers: the length of the pole (in cm) and n, the number of ants residing on the pole. These two numbers are followed by n integers giving the position of each ant on the pole as the distance measured from the left end of the pole, in no particular order. All input integers are not bigger than 1000000 and they are separated by whitespace.
Output
For each case of input, output two numbers separated by a single space. The first number is the earliest possible time when all ants fall off the pole (if the directions of their walks are chosen appropriately) and the second number is the latest possible such time. 
Sample Input
2
10 3
2 6 7
214 7
11 12 7 13 176 23 191
Sample Output
4 8
38 207

题意:在一根木条上有很多蚂蚁,初始时它们朝着一个方向运动,速度1/s,如果他们走到木条的边界,就会掉落,如果两只蚂蚁相遇,它们会掉头(不计时间),现在给你所有蚂蚁的坐标,但是方向未知,求最后一只蚂蚁离开木条最早和最晚的时间。

题解:首先假设每只蚂蚁运动的方向已知,那么考虑两只蚂蚁相遇的情况,因为掉头不需要时间,实际上可以不考虑相遇的情况,因为蚂蚁相遇后可以看作两只蚂蚁对穿而过,没有任何影响。

那么现在可以得到:最后一只离开木条的蚂蚁就是不调头,沿一个方向走,走到木条边界花费时间最长的那只。

对于这道题,方向未知,我们对每一只蚂蚁两个方向进行枚举就可以得到我们想要的答案。

例程:

#include<stdio.h>
#include<algorithm>
using namespace std;
int main()
{
    int T;
    scanf("%d",&T);
    while(T--){
        int len,n;
        int min_ans=0,max_ans=0;
        scanf("%d%d",&len,&n);
        for(int i=0;i<n;i++){
            int x;
            scanf("%d",&x);
            min_ans=max(min_ans,min(len-x,x));
            max_ans=max(max_ans,max(len-x,x));
        }
        printf("%d %d\n",min_ans,max_ans);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值