POJ 3090 Visible Lattice Points(Farey数列&欧拉函数求和)

119 篇文章 0 订阅
100 篇文章 0 订阅
Visible Lattice Points

Time Limit:  1000MS
Memory Limit: 65536K

Description

A lattice point (xy) in the first quadrant (x and y are integers greater than or equal to 0), other than the origin, is visible from the origin if the line from (0, 0) to (xy) does not pass through any other lattice point. For example, the point (4, 2) is not visible since the line from the origin passes through (2, 1). The figure below shows the points (xy) with 0 ≤ xy ≤ 5 with lines from the origin to the visible points.

Write a program which, given a value for the size, N, computes the number of visible points (xy) with 0 ≤ xy ≤ N.

Input

The first line of input contains a single integer C (1 ≤ C ≤ 1000) which is the number of datasets that follow.

Each dataset consists of a single line of input containing a single integer N (1 ≤ N ≤ 1000), which is the size.

Output

For each dataset, there is to be one line of output consisting of: the dataset number starting at 1, a single space, the size, a single space and the number of visible points for that size.

Sample Input

4
2
4
5
231

Sample Output

1 2 5
2 4 13
3 5 21
4 231 32549

Source



这一题给出的思路。

完整代码:
/*0ms,176KB*/

#include<cstdio>
#include<cstring>
using namespace std;
const int maxn = 1002;

int prime[168], phi[maxn], ans[maxn];
bool unprime[maxn];

inline void Euler()
{
	int i, j, k = 0;
	for (i = 2; i < maxn; i++)
	{
		if (!unprime[i])
		{
			prime[k++] = i;
			phi[i] = i - 1;
		}
		for (j = 0; j < k && prime[j] * i < maxn; j++)
		{
			unprime[prime[j] * i] = true;
			if (i % prime[j])
            ///此时i和p互素,则phi(i*p) = phi(i) * phi(p) = phi(i) * (p-1)
				phi[prime[j] * i] = phi[i] * (prime[j] - 1);
			///因为与p互素的i后面不可能出现(因为i越来越大),所以要继续算
			else
			{
            ///此时有i=kp,则
            ///phi(p*kp) = phi(k*p^2) = phi(k)*p*(p-1) = phi(k)*phi(p)*p = phi(kp) * p
				phi[prime[j] * i] = phi[i] * prime[j];
            ///后面遇到比p1大的p2就不用算了,因为k*p1 * p2 = k*p2 * p1,后面i=k*p2时会算出来的
				break;
			}
		}
	}
}

int main()
{
	Euler();
	int icase, n;
	ans[1] = 3;
	for (int i = 2; i < maxn; ++i)
		ans[i] = ans[i - 1] + (phi[i] << 1);
	scanf("%d", &icase);
	for (int i = 1; i <= icase ; ++i)
	{
		scanf("%d", &n);
		printf("%d %d %d\n", i, n, ans[n]) ;
	}
	return 0 ;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值