解决linux安装软件:/lib/ld-linux.so.2: bad ELF interpreter问题

这个问题不是我自己碰到的是一个同学问我在linux系统中安装软件:/lib/ld-linux.so.2: bad ELF interpreter怎么解决,这里我分析有两种,一种是常用的安装因为系统软件位数问题,如:64位系统中安装了32位程序了,另一种是交叉编译没有那个文件或目录,下面我们一起来看解决问题的方法。

问题一,64位系统中安装了32位程序解决办法
是因为64位系统中安装了32位程序
解决方法:
代码如下 复制代码
yum install glibc.i686
问题二,解决交叉编译环境错误

arm-linux-gcc hello.c -o tt

/home/gl/usr/local/arm/4.3.2/bin/arm-linux-gcc: /home/gl/usr/local/arm/4.3.2/bin/arm-none-linux-gnueabi-gcc: /lib/ld-linux.so.2: bad ELF interpreter: 没有那个文件或目录
/home/gl/usr/local/arm/4.3.2/bin/arm-linux-gcc:行3: /home/gl/usr/local/arm/4.3.2/bin/arm-none-linux-gnueabi-gcc: 成功
[root@austgl gl]# yum install ld-linux.so.2
已加载插件:langpacks, presto, refresh-packagekit
解决依赖关系
–> 执行事务检查
—> 软件包 glibc.i686.0.2.16-28.fc18 将被 安装
–> 处理依赖关系 libfreebl3.so(NSSRAWHASH_3.12.3),它被软件包 glibc-2.16-28.fc18.i686 需要
–> 处理依赖关系 libfreebl3.so,它被软件包 glibc-2.16-28.fc18.i686 需要
–> 执行事务检查
—> 软件包 nss-softokn-freebl.i686.0.3.14.3-1.fc18 将被 安装
–> 完成依赖关系计算
^[^A

依赖关系解决

Package 架构 版本 仓库 大小

正在安装:
glibc i686 2.16-28.fc18 updates 4.2 M
为依赖而安装:
nss-softokn-freebl i686 3.14.3-1.fc18 updates 146 k

事务概要

安装 1 软件包 (+1 Dependent package)
总下载量:4.3 M
安装大小:15 M
确定吗?[y/N]:y
确定吗?[y/N]:y
下载软件包:
nss-softokn-freebl-3.14.3-1.fc FAILED 105 kB/s | 301 kB 00:00:39 ETA
http://mirrors.ispros.com.bd/fed … .3-1.fc18.i686.rpm: [Errno 14] curl#22 - “Therequested URL returned error: 404 Not Found”
尝试该词语是禁止的镜像。
(1/2): glibc-2.16-28.fc18.i686.rpm | 4.2 MB 00:00:14

(2/2): nss-softokn-freebl-3.14.3-1.fc18.i686.rpm | 146 kB 00:00:35

总计 104 kB/s | 4.3 MB 00:42
运行事务检查
执行事务测试
事务测试成功
执行事务
正在安装 : nss-softokn-freebl-3.14.3-1.fc18.i686 1/2
正在安装 : glibc-2.16-28.fc18.i686 2/2
Verifying : glibc-2.16-28.fc18.i686 1/2
Verifying : nss-softokn-freebl-3.14.3-1.fc18.i686 2/2
已安装:
glibc.i686 0:2.16-28.fc18
作为依赖被安装:
nss-softokn-freebl.i686 0:3.14.3-1.fc18
完毕!
[root@austgl gl]# arm-linux-gcc hello.c -o tt
hello.c: In function ‘main’:
hello.c:3: warning: return type of ‘main’ is not ‘int’
[root@austgl gl]# file tt
tt: ELF 32-bit LSB executable, ARM, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.6.14, not stripped
[root@austgl gl]#

没有更多推荐了,返回首页