云中继

标签: 云中继
13人阅读 评论(0) 收藏 举报
分类:

第五部分,云中继。通过云中继路由器,实现不同网络之间相互通信。

网络拓扑图如下:

我们需要在每个路由器与云路由器相连的端口配置虚拟接口,以实现与其他网络的通信,配置完成后,拓扑图中的每台pc机之间能够相互通信。

代码:

##基础配置

#r0

en
conf t
int f0/0
ip add 172.168.10.1 255.255.255.0
no shut
int s0/0/0
encapsulation frame-relay
no shut
int s0/0/0.1 point-to-point
ip add 192.168.1.1 255.255.255.0
frame-relay interface-dlci 20
int s0/0/0.2 point-to-point
ip add 192.168.2.1 255.255.255.0
frame-relay interface-dlci 21
exit
router ospf 1
network 192.168.1.0 0.0.0.255 area 1
network 192.168.2.0 0.0.0.255 area 1
network 172.168.10.0 0.0.0.255 area 1

#r1

en
conf t
int f0/0
ip add 172.168.20.1 255.255.255.0
no shut
int s0/0/0
encapsulation frame-relay
no shut
int s0/0/0.1 point-to-point
ip add 192.168.1.2 255.255.255.0
frame-relay interface-dlci 30
int s0/0/0.2 point-to-point
ip add 192.168.3.1 255.255.255.0
frame-relay interface-dlci 31
exit
router ospf 1
network 192.168.1.0 0.0.0.255 area 1
network 192.168.3.0 0.0.0.255 area 1
network 172.168.20.0 0.0.0.255 area 1

#r2

en
conf t
int f0/0
ip add 172.168.30.1 255.255.255.0
no shut
int s0/0/0
encapsulation frame-relay
no shut
int s0/0/0.1 point-to-point
ip add 192.168.3.2 255.255.255.0
frame-relay interface-dlci 40
int s0/0/0.2 point-to-point
ip add 192.168.1.2 255.255.255.0
frame-relay interface-dlci 41
exit
router ospf 1
network 192.168.3.0 0.0.0.255 area 1
network 192.168.1.0 0.0.0.255 area 1
network 172.168.30.0 0.0.0.255 area 1

为每个云中继路由器上每个serial接口的DLCI取别名,方便后面面配置,比如,serial0上的DLCI20,我将它分配给与R1通信,我就取名为toR1:

配置云中继,R0要和R1通信,如果从R0到R1这边看,从R0到R1使用Serial0上的toR1,要从R1回到R0,则使用Serial1上的toR0:

 

结果检测:

pc0 ping pc2:

pc0 ping pc4:

 

查看评论

中继服务应用

  • 2013年08月08日 09:50
  • 468KB
  • 下载

如意云個件下载

  • 2015年08月21日 09:39
  • 8.25MB
  • 下载

Linux中DHCP中继代理服务器的配置详解

DHCP客户机通过广播消息获得DHCP服务器的响应后得到IP地址。但广播消息是不能跨越子网的。如果DHCP客户机和服务器在不同的子网内,客户机还能不能向服务器申请IP地址呢?这就要用到DHCP中继代理...
  • asartear
  • asartear
  • 2012-06-13 08:39:50
  • 1627

如何使用PandoraBox无线中继

  • 2014年08月18日 13:10
  • 386KB
  • 下载

Exchange中继设置

转自:点击打开链接 中继设置 什么是中继? 中继是指将邮件转发到您所在域以外的域的能力。更具体地说,当使用与您的 SMTP 服务器的入站连接来向外部域发送电子邮件时,便发生了中继...
  • happymagic
  • happymagic
  • 2014-07-07 21:12:12
  • 3572

MySQL复制应用中继日志解析

前言:SQL线程应用中继日志,在binlog_format是row格式的时候,是居于主键更新,下面结合一张图来证明。...
  • woqutechteam
  • woqutechteam
  • 2016-04-29 09:15:40
  • 6900

MW4530R Openwrt 无线路由中继设置

我接入外网的路由器是TP-Link,不需要做任何设置,这里主要介绍openwrt中建立中继的过程。 1.设置自己路由lan口的IP地址,网段和TP-link的不一样(TP-link为192.168....
  • pifangsione
  • pifangsione
  • 2013-10-27 00:02:53
  • 44281

DHCP中继、子接口配置示例

1 搭建拓扑如下图,实现不同vlan下的DHCP客户端通过中继获得IP 地址 注意事项: 1、 AR1 AR2 AR3 的各互联接口的地址必须互通,本示例启用OSPF协议实现各接口互联互通...
  • yiluyangguang1234
  • yiluyangguang1234
  • 2017-04-07 22:56:10
  • 2835

华为路由器DHCP中继

按照老师的例子搭了一个简单的拓扑,包括一个终端,两个路由器,如图: 路由器AR2  g0端口作为网关,地址:192.168.1.1 子网掩码:255.255.255.0 g1端口    ...
  • flyfish5
  • flyfish5
  • 2015-12-08 21:05:09
  • 4483

H3C交换机设置DHCP中继,配合Linux 服务器为多VLAN提供D ...

H3C交换机设置DHCP中继,配合Linux 服务器为多VLAN提供DHCP地址分配服务 wanghaoqd   最近在单位用Linux做了一台DHCP服务器,使用H3C S7506R交换...
  • candy_578079476
  • candy_578079476
  • 2017-04-10 00:50:49
  • 1244
    个人资料
    等级:
    访问量: 0
    积分: 205
    排名: 0
    文章存档
    最新评论