yum安装git-v2.x版本

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/t3369/article/details/79562853

在bower项目的时候显示如下报错

访问提示中的网址报如下信息

Please upgrade your git client.
GitHub.com no longer supports git over dumb-http: https://github.com/blog/809-git-dumb-http-transport-to-be-turned-off-in-90-days

就是说需要升级git,我的操作系统是centos6.5,git版本是再带的V1.7.1(使用git --version 查看)

首先卸载旧版本git

yum remove git  
直接使用这个命令下载的还是1.7.1版本的。不使用源码进行编译是因为依赖太多,总会缺东西。
yum install git

可以使用 WANDisco's CentOS repository去安装 Git 2.x.

  1. Install WANDisco repo package:

yum install http://opensource.wandisco.com/centos/6/git/x86_64/wandisco-git-release-6-1.noarch.rpm
  1. Install the latest version of Git 2.x:
yum install git

如果再bower时出现SSL connect error,执行

git config --global http.sslversion tlsv1

没有更多推荐了,返回首页

私密
私密原因:
请选择设置私密原因
  • 广告
  • 抄袭
  • 版权
  • 政治
  • 色情
  • 无意义
  • 其他
其他原因:
120
出错啦
系统繁忙,请稍后再试

关闭