Problem H

Problem Description
There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows:
(a) The setup time for the first wooden stick is 1 minute.
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l <= l' and w <= w'. Otherwise, it will need 1 minute for setup.
You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are ( 9 , 4 ) , ( 2 , 5 ) , ( 1 , 2 ) , ( 5 , 3 ) , and ( 4 , 1 ) , then the minimum setup time should be 2 minutes since there is a sequence of pairs ( 4 , 1 ) , ( 5 , 3 ) , ( 9 , 4 ) , ( 1 , 2 ) , ( 2 , 5 ) .
 

Input
The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1 <= n <= 5000 , that represents the number of wooden sticks in the test case, and the second line contains 2n positive integers l1 , w1 , l2 , w2 ,..., ln , wn , each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.
 

Output
The output should contain the minimum setup time in minutes, one per line.
 

Sample Input
  
  
3 5 4 9 5 2 2 1 3 5 1 4 3 2 2 1 1 2 2 3 1 3 2 2 3 1
 

Sample Output
2
1
3
 
 
简单题意:
  
  
  有一堆木棍需要处理,事先已经知道了他们的长度和重量。木棍处理机器需要为第一根木棍留下1min的设置时间,然后其他的木棍如果长度比第一根大并且重量也比第一根重,那么机器将不需要设置时间。否则,需要重新开始设置,耗费1min的设置时间。编写一个程序,使得处理完这批木棍的时间最短。
解题思路形成过程:
  这个题目,拿到手,第一反应,怎么和problem B一模一样?!当时也没仔细看题就把AC代码提交上去了。其实不然,这个题的排序方式是按照重量来的。同样,也是贪心算法,类似problem B。
感想:
  老师果然不会迷糊出两个一模一样的题目,审题要仔细。ACM要稳准细才能更好地理解题意,写出算法。
AC代码:
#include <iostream>
#include <algorithm>
using namespace std;
struct stick
{
    int l;
    int w;
};
bool cmp(const stick &a,const stick &b)
{
    if(a.w<=b.w)return true;//所有的数据从小到大排序
    return false;
    }
void greedy_select(int n,stick a[],bool b[])
{
    b[1]=true;
    int preEnd=1;
    for(int i=2;i<=n;i++)
    {
        if(a[i].l>=a[preEnd].l&&a[i].w>=a[preEnd].w)
        {
            b[i]=true;
            preEnd=i;
        }
        else b[i]=false;
        }
    }
int main()
{
    int n,stickNum;
    stick s[5001];
    bool f[5001];
    while(cin>>n)
    {
        for(int k=0;k<n;k++)
        {
        cin>>stickNum;
        for(int i=1;i<=stickNum;i++)
        {
            cin>>s[i].l>>s[i].w;
            }
        sort(s+1,s+stickNum+1,cmp);
        int sum=0;
        while(stickNum!=0)
        {
            greedy_select(stickNum,s,f);
            int j=1,total=0;
            for(int i=1;i<=stickNum;i++)
            {
            if(f[i]){total++;}
            else
            {
                s[j]=s[i];
                //cout<<"j:"<<j<<endl;
                j++;
                }
            }
            //cout<<"total:"<<total<<endl;
            sum++;
            stickNum-=total;
        }
        cout<<sum<<endl;
        }
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值