FOJ_1001_Duplicate Pair

64 篇文章 0 订阅
23 篇文章 0 订阅

  

An array of length n, with address from 1 to n inclusive, contains entries from the set {1,2,...,n-1} and there's exactly two elements with the same value. Your task is to find out the value.

Input

Input contains several cases.
Each case includes a number n (1<n<=10^6), which is followed by n integers.
The input is ended up with the end of file.

Output

Your must output the value for each case, one per line.

Sample Input

2
1 1
4
1 2 3 2

Sample Output

1
2
 

#include<stdio.h>

int main()

{

long long int sum,num;

long int n,a,cfs,i;

while(scanf("%ld",&n)!=EOF)

{

num=0;

sum=0;

for(i=1;i<n;i++)

sum+=i;

for(i=0;i<n;i++)

{

scanf("%ld",&a);

num+=a;

}

cfs=num-sum;

printf("%ld/n",cfs);

}

return 0;

}

 我是直接暴力算-___________________-

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值