POJ 1979

Red and Black
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 33344 Accepted: 18138
Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can’t move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.
Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

‘.’ - a black tile
‘#’ - a red tile
‘@’ - a man on a black tile(appears exactly once in a data set)
The end of the input is indicated by a line consisting of two zeros.
Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
Sample Input

6 9
….#.
…..#
……
……
……
……
……
#@…#
.#..#.
11 9
.#………
.#.#######.
.#.#…..#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#…….#.
.#########.
………..
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..

.

…@…

.

..#.#..
..#.#..
0 0
Sample Output

45
59
6
13
Source

Japan 2004 Domestic
题目翻译:
有一个地上密铺了正方形瓷砖长方形的房间。每个瓷砖的颜色不是红色就是黑色。有一个人站在其中的一个黑色的瓷砖上。他可以往上、下、左、右四个方向走动。但是他只能走在黑色的瓷砖上,而不能走在红色的瓷砖上。
写一个程序以计算他最多能走多少步。
解题思路
这是一道很水的标准DFS,只要注意判断不要超出边界就可以啦。
输入的时候是先输入列数、后输入行数的,注意一下就好啦

直接附上程序

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cmath>
#include <string>
#include <cstring>
#include <vector>
#include <queue>
#include <stack>
#include <iomanip>
#include <set>
#include <map>


using namespace std;


int M,N,res;
char field[105][105];


void dfs(int x,int y){
//  cout << x << " " << y <<endl;
    field[x][y] = '#';
    res++;
    int nx = x + 1 , ny = y + 0;
    if (0 <= nx && nx < N && 0 <= ny && ny < M && field[nx][ny] == '.') dfs(nx,ny);
     nx = x - 1,ny = y+0;
    if (0 <= nx && nx < N && 0 <= ny && ny < M && field[nx][ny] == '.') dfs(nx,ny);
     nx = x + 0,ny = y-1;
    if (0 <= nx && nx < N && 0 <= ny && ny < M && field[nx][ny]=='.')   dfs(nx,ny);
     nx = x + 0,ny = y + 1;
    if (0 <= nx && nx < N && 0 <= ny && ny < M && field[nx][ny]=='.')   dfs(nx,ny);
    return;
}


int main()
{
    while (cin >> M >> N && N!=0 && M!=0){
        res=0;
        for (int i=0;i<N;++i){
            for (int j=0;j<M;++j){
                cin >> field[i][j];
            }
        }
        for (int i=0;i<N;++i){
            for (int j=0;j<M;++j){
                if (field[i][j]=='@'){
                    dfs(i,j);
                }
            }
        }
        cout<<res<<endl; 
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值