poj 1704

Georgia and Bob
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 5011 Accepted: 1357

Description

Georgia and Bob decide to play a self-invented game. They draw a row of grids on paper, number the grids from left to right by 1, 2, 3, ..., and place N chessmen on different grids, as shown in the following figure for example:

Georgia and Bob move the chessmen in turn. Every time a player will choose a chessman, and move it to the left without going over any other chessmen or across the left edge. The player can freely choose number of steps the chessman moves, with the constraint that the chessman must be moved at least ONE step and one grid can at most contains ONE single chessman. The player who cannot make a move loses the game.

Georgia always plays first since "Lady first". Suppose that Georgia and Bob both do their best in the game, i.e., if one of them knows a way to win the game, he or she will be able to carry it out.

Given the initial positions of the n chessmen, can you predict who will finally win the game?

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case contains two lines. The first line consists of one integer N (1 <= N <= 1000), indicating the number of chessmen. The second line contains N different integers P1, P2 ... Pn (1 <= Pi <= 10000), which are the initial positions of the n chessmen.

Output

For each test case, prints a single line, "Georgia will win", if Georgia will win the game; "Bob will win", if Bob will win the game; otherwise 'Not sure'.

Sample Input

2
3
1 2 3
8
1 5 6 7 9 12 14 17

Sample Output

Bob will win
Georgia will win

Source

题意:向左移动棋子,不可越过其他棋子。
分析:奇异局势必定是,两两棋子相邻为一组,前手移动左边的棋子,后手只需紧贴就可以了。所以无需考虑组合组之间的空隙,而组内棋子之间的距离相当于取石子
#include <cstdio>
#include<string.h>
#include<algorithm>
using namespace std;
int main(int argc, char *argv[])
{
	int T,n,a[1011],b[1011],i,sum,k;
	scanf("%d",&T);
	while(T--)
	{
		sum=0;
		scanf("%d",&n);
		for (i=0;i<n;i++)
        	scanf("%d",&a[i]);
        sort(a,a+n);//这里就是错的地方,题目并没有说已经排好序 
 	    if (n%2==0) 
        {
        	k=0;
        	for (i=1;i<n;i=i+2)
        	{
			   b[k++]=a[i]-a[i-1]-1; //两个数字间的个数需要减一 
			}
		}
		else 
		{
			k=1;
			b[0]=a[0]-1;
			for (i=2;i<n;i=i+2)
			{
				b[k++]=a[i]-a[i-1]-1;//赋予K值保证B数组中是连续的 
			}
		}
		for (i=0;i<k;i++)
        {
		     sum^=b[i];
	    }
	    if(sum) printf("Georgia will win\n");
	    else printf("Bob will win\n");
	}
	return 0;
}




 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值