T - Catch That Cow Catch That Cow

Catch That Cow

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input
Line 1: Two space-separated integers: N and K

Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input
5 17

Sample Output
4
Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

 题意:给你三种方式,{-1,+1,*2},使n到k。求所用最少步数;

思路:广搜。因为三种方式的判断条件不同,所以分开写;

代码:

 
 
#include<queue>
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
#define mem(a,b) memset(a,b,sizeof(a))
using namespace std;
struct za
{
    int s,step;
};
int n,k;
za now,nex;
int book[200010]={0};
void bfs()
{
queue<za>qaq;
book[n]=1;
now.s=n;
now.step=0;
qaq.push(now);
while(!qaq.empty())
{
now=qaq.front();
qaq.pop();
if(now.s==k) //到k返回最少步数
{
printf("%d\n",now.step);
return;
}
if(now.s>=1&&!book[now.s-1]) // -1方式。n-1>0
{
    nex.s=now.s-1;
   nex.step=now.step+1;
book[nex.s]=1; qaq.push(nex);
}
if(now.s<k&&!book[now.s+1]) //+1方式。因为n+1要<=k.如果n>k,只能用-1的方式,不存在再用+1的方式。
{
nex.s=now.s+1;
nex.step=now.step+1;
book[nex.s]=1;
qaq.push(nex);
}
if(now.s<100005&&!book[now.s*2]) //n*2可以大于k,大于k了的话,可以用-1的方式。
{
nex.s=now.s*2;
nex.step=now.step+1;
book[nex.s]=1;
qaq.push(nex);
}
}
}
int main()
{
scanf("%d%d",&n,&k);
mem(book,0);
bfs();
return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值