F - 野茫茫 HDU - 1010

 

F - 野茫茫

 HDU - 1010                         

  

 

The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze. 

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him. 

InputThe input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following: 

'X': a block of wall, which the doggie cannot enter; 
'S': the start point of the doggie; 
'D': the Door; or 
'.': an empty block. 

The input is terminated with three 0's. This test case is not to be processed. 
OutputFor each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise. 
Sample Input

4 4 5
S.X.
..X.
..XD
....
3 4 5
S.X.
..X.
...D
0 0 0

Sample Output

NO
YES

 

题意:小狗要在第T秒的时候正好到door门口。问你是否可以?

思路:深搜枚举,加入 奇偶剪枝优化;

代码:

#include <iostream>
#include<cstdio>
#include<queue>
#include<cstring>
#include<string>
#include<algorithm>
using namespace std;
#define mem(a,b) memset(a,b,sizeof(a))
int ne[4][2]= {-1,0,1,0,0,1,0,-1};
int book[10][10];
char tu[10][10];
int n,m,T,sx,sy,flag,dx,dy;
bool jud(int aa,int bb)
{
    if(aa>=0&&aa<n&&bb>=0&&bb<m&&!book[aa][bb]&&tu[aa][bb]!='X')
        return 1;
    return 0;
}
int abs(int ab)
{
    if(ab<0)
        return -ab;
    return ab;
}
void dfs(int a,int b,int tm)
{
    int tx,ty;
    if(tm==T&&tu[a][b]=='D')
     {
          flag=1;
          return;
     }
    if(flag)
        return;
    int ss=abs(a-dx)+abs(b-dy);
    
    if((T-ss-tm)%2||ss+tm>T)  //奇偶剪枝 或 如果最短距离+步数>时间T,那就到不了;
        return;
    for(int i=0;i<4;i++)
    {
        tx=a+ne[i][0];
        ty=b+ne[i][1];
        if(jud(tx,ty))
        {
            book[tx][ty]=1;
            dfs(tx,ty,tm+1);
            book[tx][ty]=0;
        }
    }
    return;
}
int main()
{
    while(~scanf("%d %d %d",&n,&m,&T)&&(n||m||T))
    {
        getchar();
        mem(book,0);
        for(int i=0;i<n;i++)
        {
            scanf("%s",tu[i]);
            for(int j=0;j<m;j++)
            {
                if(tu[i][j]=='S')
                {
                    sx=i;
                    sy=j;
                }
                if(tu[i][j]=='D')
                {
                    dx=i;
                    dy=j;
                }
            }
        }
        flag=0;
        book[sx][sy]=1;
        int s=abs(dx-sx)+abs(dy-sy);
       
        if((s+T)%2)     //最短距离与时间T不是同奇偶,直接输出;
        {
            printf("NO\n");
            continue;
        }
        dfs(sx,sy,0);
        if(flag)
            printf("YES\n");
        else
            printf("NO\n");
    }
    return 0;
}

 

 

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值