G - Power Strings (KMP——最小循环节)

G - Power Strings

 

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

 

题意:

             求最小循环节个数

注:

      1)当输入" . " (最后一个样例),结束。

       2)数据范围1~1000000

       3)当S长度不能除尽循环节时,输出1;

代码:

#include<map>
#include<cstdio>
#include<string>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
#define Mlm 1000005    //数据范围1~1000000
int ne[Mlm];
char mo[Mlm];
int lm,lt;
void nex()
{
    int i=0,j=-1;
    ne[0]=-1;
    while(i<lm)
    {
        while(j!=-1&&mo[j]!=mo[i])
            j=ne[j];
        ne[++i]=++j;
    }
}
int main()
{

    while(~scanf("%s",mo))
    {
        if(mo[0]=='.')
            break;
        memset(ne,0,sizeof(ne));
        lm=strlen(mo);
        nex();
        int Xun=lm-ne[lm];    //求最小循环节

        if(lm%(Xun)!=0)     //当S长度不能除尽循环节时,输出1;
            printf("1\n");
        else
            printf("%d\n",lm/Xun);
    }
return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值