hdu 1068 Girls and Boys(最大独立集·maxmatch匈牙利)

题目:http://acm.hust.edu.cn/vjudge/problem/viewProblem.action?id=19391

Time Limit: 10000MS Memory Limit: 32768KB 64bit IO Format: %I64d & %I64u

 Status

Description

the second year of the university somebody started a study on the romantic relations between the students. The relation “romantically involved” is defined between one girl and one boy. For the study reasons it is necessary to find out the maximum set satisfying the condition: there are no two students in the set who have been “romantically involved”. The result of the program is the number of students in such a set. 

The input contains several data sets in text format. Each data set represents one set of subjects of the study, with the following description: 

the number of students 
the description of each student, in the following format 
student_identifier:(number_of_romantic_relations) student_identifier1 student_identifier2 student_identifier3 ... 
or 
student_identifier:(0) 

The student_identifier is an integer number between 0 and n-1, for n subjects. 
For each given data set, the program should write to standard output a line containing the result. 
 

Sample Input

    
    
7 0: (3) 4 5 6 1: (2) 4 6 2: (0) 3: (0) 4: (2) 0 1 5: (1) 0 6: (2) 0 1 3 0: (2) 1 2 1: (1) 0 2: (1) 0
 

Sample Output

    
    
5 2
 

Source

Southeastern Europe 2000

 Status

求不属于匹配关系的人数。
二分最大匹配后的匹配数是结果的2倍:

最大独立集=总个数-最大匹配数(U=n-maxmatch+maxmatch/2=n-maxmatch/2,n-maxmatch是绝对的未匹配,+maxmatch/2是加上完全拆开后的独立个数)。综上,敲代码。。。
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
const int maxn=1e3+5;
bool bmap[maxn][maxn],bmask[maxn];
int nx,ny;
int cx[maxn],cy[maxn];
int times=0;
int findpath(int u){
    for(int j=1;j<=ny;j++){
        if(bmap[u][j] && !bmask[j]){
             bmask[j]=1;
             if(cy[j]==-1 || findpath(cy[j])){
                  cy[j]=u;
                  cx[u]=j;
                  return 1;
             }
        }
    }
    return 0;
}
int maxmatch(){
    int res=0;
    memset(cx,-1,sizeof(cx));
    memset(cy,-1,sizeof(cy));
    for(int i=1;i<=nx;i++){
        if(cx[i]==-1){
             for(int j=1;j<=ny;j++)   bmask[j]=0;
             res+=findpath(i);
        }
    }
    return res;
}
int main()
{
    //freopen("cin.txt","r",stdin);
    int n;
    while(cin>>n){
        nx=ny=n;
        memset(bmap,0,sizeof(bmap));
        int ix,iy,rela;
        while(n--){
             scanf("%d",&ix);
             while(getchar()!='(');
             scanf("%d)",&rela);
             while(rela--){
                 scanf("%d",&iy);
                 bmap[ix+1][iy+1]=1;
             }
        }
        int ans=maxmatch();
        ans=nx-ans+ans/2;
        printf("%d\n",ans);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值