poj 2503 Babelfish(字典树·翻译)

题目:http://poj.org/problem?id=2503

Language:
Babelfish
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 37107 Accepted: 15811

Description

You have just moved from Waterloo to a big city. The people here speak an incomprehensible dialect of a foreign language. Fortunately, you have a dictionary to help you understand them.

Input

Input consists of up to 100,000 dictionary entries, followed by a blank line, followed by a message of up to 100,000 words. Each dictionary entry is a line containing an English word, followed by a space and a foreign language word. No foreign word appears more than once in the dictionary. The message is a sequence of words in the foreign language, one word on each line. Each word in the input is a sequence of at most 10 lowercase letters.

Output

Output is the message translated to English, one word per line. Foreign words not in the dictionary should be translated as "eh".

Sample Input

dog ogday
cat atcay
pig igpay
froot ootfray
loops oopslay

atcay
ittenkay
oopslay

Sample Output

cat
eh
loops

Hint

Huge input and output,scanf and printf are recommended.
分析:这和hdu 1075 what are you talking about 很像,甚至比它还要简单。就是利用字典树进行单词翻译。

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
struct node{
    bool cover;
    char word[15];
    node *next[26];
    node(){
        cover=0;
        memset(word,0,sizeof(word));
        memset(next,0,sizeof(next));
    }
};
node *root;
void insert(char *s1,char *s2){
    node *p=root;
    int length=strlen(s2);
    for(int i=0;i<length;i++){
        if(p->next[s2[i]-'a']==0) p->next[s2[i]-'a']=new node();
        p=p->next[s2[i]-'a'];
    }
    p->cover=1;
    strcpy(p->word,s1);
}
void del(node *p){
    if(p==NULL){  return ;  }
    for(int i=0;i<26;i++) del(p->next[i]);
    delete p;
}
char* query(char *s){
    int length=strlen(s);
    node *p=root;
    for(int i=0;i<length;i++){
        if(p->next[s[i]-'a']==0) return 0;
        p=p->next[s[i]-'a'];
    }
    if(p->cover) return p->word;
    return 0;
}
char str[30],s1[15],s2[15];
void strcpy(char *s,char *f,int start,int end){
    for(int i=start;i<=end;i++){
        s[i-start]=f[i];
    }
    s[end-start+1]=0;
}
int main()
{
    //freopen("cin.txt","r",stdin);
    root=new node();
    while(gets(str)){
        int length1,slen=strlen(str);  //slen=0意味着空行
        if(slen==0) break;
        for(int i=0;i<slen;i++){
            if(str[i]==' '){
                length1=i;
                break;
            }
        }
        strcpy(s1,str,0,length1-1);
        strcpy(s2,str,length1+1,slen-1);
        //cout<<s1<<" "<<s2<<endl;
        insert(s1,s2);
    }
    while(~scanf("%s",s1)){
        char *ans=query(s1);  //返回字符串
        if(ans) printf("%s\n",ans);
        else printf("eh\n");
    }
    del(root);
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值