hdu 5867 Water problem

Water problem

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1067    Accepted Submission(s): 446


Problem Description
If the numbers 1 to 5 are written out in words: one, two, three, four, five, then there are 3+3+5+4+4=19 letters used in total.If all the numbers from 1 to n (up to one thousand) inclusive were written out in words, how many letters would be used?

Do not count spaces or hyphens. For example, 342 (three hundred and forty-two) contains 23 letters and 115 (one hundred and fifteen) contains 20 letters. The use of "and" when writing out numbers is in compliance with British usage.
 

Input
There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases.

For each test case: There is one positive integer not greater one thousand.
 

Output
For each case, print the number of letters would be used.
 

Sample Input
  
  
3 1 2 3
 

Sample Output
  
  
3 6 11
 


这道题需要打表,因为英文里表示数字的格式就那么几个,把1-1000的单词里字母使用量打表存起来就好。第一次wa是因为忘了打1000的表了。。。



#include<iostream>
#include<cstring>
using namespace std;
int es[21]={0,3,3,5,4,4,3,5,5,4,3,6,6,8,8,7,7,9,8,8,6};
int sw[12]={0,0,6,6,5,5,5,7,6,6};
int main()
{
	int l[1111];
	int i;
	for(i=1;i<=999;i++)
	{
		int a=i/100;
		int b=i%100/10;
		int c=i%10;
		int ans=0;
		if(a!=0)
		{
			ans=ans+es[a];
			ans=ans+7;
			if(b!=0||c!=0)
			ans=ans+3;
		}
		if(b>=2)
		{
			ans=ans+sw[b];
			ans=ans+es[c];
		}
		if(b>=0&&b<2)
		{
			ans=ans+es[b*10+c];
		}
	    l[i]=ans;
	}
	l[1000]=11;
	int n;
	int T;
	cin>>T;
	while(T--)
	{
		cin>>n;
		long long int ans1=0;
		for(i=1;i<=n;i++)
		{
			ans1+=l[i];
		}
		cout<<ans1<<endl;
	}
	return 0;
 } 


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值