poj 3624

1 篇文章 0 订阅

Description

Bessie has gone to the mall’s jewelry store and spies a charm bracelet. Of course, she’d like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi ≤ 400), a ‘desirability’ factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

Input

  • Line 1: Two space-separated integers: N and M
  • Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

Output

  • Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

Sample Input

4 6
1 4
2 6
3 12
2 7
Sample Output

23


代码

#include <iostream>
using namespace std;

//***********************常量定义*****************************

const int MAX_NUM = 3500;
const int MAX_WEIGHT = 14000;

//*********************自定义数据结构*************************



//********************题目描述中的变量************************

int weight[MAX_NUM];
int value[MAX_NUM];


//**********************算法中的变量**************************

//进行空间压缩,使用一维数组
int dp[MAX_WEIGHT];


//***********************算法实现*****************************

void Solve( int n, int w )
{   
    for( int i=1; i<=n; i++ )
    {
        //因为使用了一维数组,所有j要按照递减顺序
        for( int j=w; j>=weight[i]; j-- )
        {           
            if( dp[j-weight[i]] + value[i] > dp[j] )
                dp[j] = dp[j-weight[i]] + value[i];         
        }
    }
    cout << dp[w] << endl;
}


//************************main函数****************************

int main()
{
    //freopen( "in.txt", "r", stdin );  

    int n, w;
    cin >> n >> w;      

    for( int i=1; i<=n; i++ )
    {
        cin >> weight[i] >> value[i];
    }
    Solve( n, w );

    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值