【PAT】1020. Tree Traversals

1020. Tree Traversals (25)

时间限制
400 ms
内存限制
32000 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
7
2 3 1 5 7 6 4
1 2 3 4 5 6 7
Sample Output:
4 1 6 3 5 7 2


题意:根据后序遍历、中序遍历结果,生成 层次遍历。


代码如下:

#include <iostream>
#include <fstream>

using namespace std;

ifstream fin("in.txt");
#define cin fin
#define MAXLEN 31

int postOrder[MAXLEN];
int inOrder[MAXLEN];
int store[MAXLEN][17]={0};

int findIndex(int key,int inBegin,int inEnd)	//在中序遍历中寻找父节点
{
	for(int i=inBegin;i<=inEnd;i++)
	{
		if(inOrder[i]==key)return i;
	}
	return -1;
}

void levelOrder(int begin,int end,int inBegin,int inEnd,int level)
{
	if(begin>end)return;

	store[level][0]++;
	store[level][store[level][0]] = postOrder[end];

	if(begin==end)return;

	int inIndex=findIndex(postOrder[end],inBegin,inEnd);
	int postIndex = begin + inIndex - inBegin;		//根据inIndex左子节点的数目来计算后序遍历的中间点

	levelOrder(begin,postIndex-1,inBegin,inIndex-1,level+1);
	levelOrder(postIndex,end-1,inIndex+1,inEnd,level+1);
}

int main()
{
	int n;
	cin>>n;

	int i;
	for(i=0;i<n;i++)
		cin>>postOrder[i];
	for(i=0;i<n;i++)
		cin>>inOrder[i];

	levelOrder(0,n-1,0,n-1,0);
	
	cout<<store[0][1];
	
	int le = 1;
	int num = store[le][0];
	while(num)
	{
		for(i=0;i<num;i++)
		{
			cout<<' '<<store[le][i+1];
		}
		le++;
		num = store[le][0];
	}
	cout<<endl;
	system("PAUSE");
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值