【PAT 1017】 Queueing at Bank 模拟算法

1017. Queueing at Bank (25)

时间限制
400 ms
内存限制
32000 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Suppose a bank has K windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. All the customers have to wait in line behind the yellow line, until it is his/her turn to be served and there is a window available. It is assumed that no window can be occupied by a single customer for more than 1 hour.

Now given the arriving time T and the processing time P of each customer, you are supposed to tell the average waiting time of all the customers.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (<=10000) - the total number of customers, and K (<=100) - the number of windows. Then N lines follow, each contains 2 times: HH:MM:SS - the arriving time, and P - the processing time in minutes of a customer. Here HH is in the range [00, 23], MM and SS are both in [00, 59]. It is assumed that no two customers arrives at the same time.

Notice that the bank opens from 08:00 to 17:00. Anyone arrives early will have to wait in line till 08:00, and anyone comes too late (at or after 17:00:01) will not be served nor counted into the average.

Output Specification:

For each test case, print in one line the average waiting time of all the customers, in minutes and accurate up to 1 decimal place.

Sample Input:
7 3
07:55:00 16
17:00:01 2
07:59:59 15
08:01:00 60
08:00:00 30
08:00:02 2
08:03:00 10
Sample Output:
8.2
题意:

银行排队

分析:

简单的的模拟算法。

代码:

#include <iostream>
#include <fstream>
#include <algorithm>
#include <vector>
#include <cstring>
#include <iomanip>
using namespace std;

//此代码使用前,需删除下面两行+后面的system("PAUSE")
ifstream fin("in.txt");
#define cin fin

struct Customer{
	int arrtime;
	int servetime;
};
const int late = 17*3600;
Customer cus[10000];
int window[100]={0};
int n,k;

int char2Int(char c[]){
	int hour = (c[0]-'0')*10+c[1]-'0';
	int minute = (c[3]-'0')*10+c[4]-'0';
	int second = (c[6]-'0')*10+c[7]-'0';
	return hour*3600+minute*60+second;
}

bool cmp(const Customer& a,const Customer& b){
	return a.arrtime < b.arrtime;
}

int waitWindow(const Customer& c){		//返回该客户等待时间
	int waittime = 0;
	int early = 0x7fffffff;
	int index;
	for(int i=0;i<k;i++){
		if(window[i] <= c.arrtime){
			window[i]= c.arrtime + c.servetime;
			waittime = 0;
			return 0;
		}else{
			if(early > window[i]){
				early = window[i];
				index = i;
			} 
		}
	}
	waittime = window[index]-c.arrtime;
	window[index] = window[index] + c.servetime;
	return waittime;
}

int main()
{
	cin>>n>>k;
	int i,j=0;
	char arr[10];
	int arrive;
	int time,sec;
	for(i=0;i<n;i++){
		cin>>arr>>time;
		arrive = char2Int(arr);
		sec = time*60;
		if(arrive<=late){
			cus[j].arrtime = arrive;
			cus[j].servetime = sec;
			j++;
		}
	}
	n=j;
	sort(cus,cus+n,cmp);
	for(i=0;i<k;i++)
		window[i]=8*3600;
	int sumWait = 0;
	for(i=0;i<n;i++){
		sumWait += waitWindow(cus[i]);
	}
	printf("%.1f\n",(float)sumWait/n/60);
	//cout<<setiosflag(std::fixed)<<(float)sumWait/n/60<<endl;
	system("PAUSE");
	return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值