UVA10162 Last Digit【数学规律】

Give you a integer number N (1 ≤ n ≤ 2 ∗ 10100). Please compute
S = 11 + 22 + 33 + . . . + NN
Give the last digit of S to me.
Input
Input file consists of several N’s, each N a line. It is ended with N = 0.
Output
For each N give a line containing only one digit, which is the last digit of S.
Sample Input
1
2
3
0
Sample Output
1
5
2

问题链接UVA10162 Last Digit
问题简述:给定n,计算S = 11 + 22 + 33 + . . . + NN的最后1位数字。
问题分析:数学规律题,通过打表找规律,可以发现到1-100后开始循环。进一步可以发现每20个又有规律。
程序说明:(略)
参考链接:(略)
题记:(略)

AC的C++语言程序如下:

/* UVA10162 Last Digit */

#include <bits/stdc++.h>

using namespace std;

const int m[] = {0,1,5,2,8,3,9,2,8,7,7,8,4,7,3,8,4,1,5,4};
const int N = 100 + 2;
char s[N];

int main()
{
    while(~scanf("%s", s)) {
        int len = strlen(s);
        if(len == 1 && s[0] == '0') break;

        int a = s[len - 1] - '0';
        if(len > 1)
            a += (s[len - 2] - '0') * 10;

        printf("%d\n", (m[a % 20] + a / 20 * 4) % 10);
    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值