UVALive6969 ZOJ3819 Average Score【水题】

 

Average Score


Time Limit: 2 Seconds      Memory Limit: 65536 KB


 

Bob is a freshman in Marjar University. He is clever and diligent. However, he is not good at math, especially in Mathematical Analysis.

After a mid-term exam, Bob was anxious about his grade. He went to the professor asking about the result of the exam. The professor said:

"Too bad! You made me so disappointed."

"Hummm... I am giving lessons to two classes. If you were in the other class, the average scores of both classes will increase."

Now, you are given the scores of all students in the two classes, except for the Bob's. Please calculate the possible range of Bob's score. All scores shall be integers within [0, 100].

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains two integers N (2 <= N <= 50) and M (1 <= M <= 50) indicating the number of students in Bob's class and the number of students in the other class respectively.

The next line contains N - 1 integers A1, A2, .., AN-1 representing the scores of other students in Bob's class.

The last line contains M integers B1, B2, .., BM representing the scores of students in the other class.

Output

For each test case, output two integers representing the minimal possible score and the maximal possible score of Bob.

It is guaranteed that the solution always exists.

Sample Input

2
4 3
5 5 5
4 4 3
6 5
5 5 4 5 3
1 3 2 2 1

Sample Output

4 4
2 4

 

Regionals 2014 >> Asia - Mudanjiang

 

 

 

问题链接UVALive6969 ZOJ3819 Average Score

问题简述

  Bob班里有n个人(包括Bob),邻班有n个人。若Bob不在本班,加入到邻班,两班的平均分都会增加。给出Bob班里n-1个人的分数以及邻班m个人的分数,问Bob分数可能的最小值和最大值是多少。

问题分析

  假设Bob分数为x,Bob班分数和为suma,邻班分数和为sumb,则必须满足suma/(n-1) >= x >= sumb/(m + 1)。Bob的成绩必须在整数域中进行考虑,比邻班平均成绩的要多1分,比本班的平均成绩要少1分。

程序说明:(略)

 

AC通过的C语言程序如下:

 

/* UVALive6969 ZOJ3819 Average Score */

#include <stdio.h>

int main(void)
{
    int t, n, m, suma, sumb, val, min, max, i;

    scanf("%d", &t);
    while(t--) {
        scanf("%d%d", &n, &m);

        suma = 0;
        for(i=1; i<=n-1; i++) {
            scanf("%d", &val);
            suma += val;
        }
        sumb = 0;
        for(i=1; i<=m; i++) {
            scanf("%d", &val);
            sumb += val;
        }

        min = sumb / m + 1;
        max = (suma % (n-1) == 0) ? suma / (n-1) - 1 : suma / (n-1);

        printf("%d %d\n", min, max);
    }

    return 0;
}

 

 

 

 

 

 

 

 

 

 

 

 

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值