UVALive3635 UVA12097 POJ3122 HDU1969 Pie【二分查找】

708 篇文章 18 订阅
509 篇文章 6 订阅

Pie
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 19806 Accepted: 6438 Special Judge

Description

My birthday is coming up and traditionally I'm serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though.  

My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size.  

What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.

Input

One line with a positive integer: the number of test cases. Then for each test case:
  • One line with two integers N and F with 1 ≤ N, F ≤ 10 000: the number of pies and the number of friends.
  • One line with N integers ri with 1 ≤ ri ≤ 10 000: the radii of the pies.

Output

For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10 −3.

Sample Input

3
3 3
4 3 3
1 24
5
10 5
1 4 2 3 4 5 6 5 4 2

Sample Output

25.1327
3.1416
50.2655

Source


Regionals 2006 >> Europe - Northwestern


问题链接UVALive3635 UVA12097 POJ3122 HDU1969 Pie

问题简述:(略)

问题分析:二分查找。不解释。

程序说明(略)

题记:(略)

参考链接:(略)


AC的C++语言程序如下:

/* UVALive3635 UVA12097 POJ3122 HDU1969 Pie */

#include <iostream>
#include <stdio.h>
#include <math.h>

using namespace std;

const double PI = acos(-1.0);
const double EPS = 1e-7;            // 精度

const int N = 10000;
double a[N];
int n, f;

bool check(double mid)
{
    int cnt = 0;
    for(int i=0; i<n; i++)
        cnt += int(a[i] / mid);
    return cnt >= f + 1;
}

int main()
{
    int t, r;
    double sum, left, right, mid;

    scanf("%d", &t);
    while(t--) {
        scanf("%d%d", &n, &f);

        sum = 0;
        for(int i=0; i<n; i++) {
            scanf("%d", &r);
            a[i] = PI * r * r;
            sum += a[i];
        }

        left = 0;
        right = sum / (f + 1);
        while(right - left > EPS) {
            mid = (left + right) / 2;

            if(check(mid))
                left = mid;
            else
                right = mid;
        }

        printf("%.4f\n", mid);
    }

    return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值