UVA674 Coin Change【0/1背包+DP】

Suppose there are 5 types of coins: 50-cent, 25-cent, 10-cent, 5-cent, and 1-cent. We want to makechanges with these coins for a given amount of money.

  For example, if we have 11 cents, then we can make changes with one 10-cent coin and one 1-centcoin, two 5-cent coins and one 1-cent coin, one 5-cent coin and six 1-cent coins, or eleven 1-cent coins.So there are four ways of making changes for 11 cents with the above coins. Note that we count thatthere is one way of making change for zero cent.

  Write a program to find the total number of different ways of making changes for any amount ofmoney in cents. Your program should be able to handle up to 7489 cents.

Input

The input file contains any number of lines, each one consisting of a number for the amount of moneyin cents.

Output

For each input line, output a line containing the number of different ways of making changes with theabove 5 types of coins.

Sample Input

11

26

Sample Output

4

13

 

 

问题链接UVA674 Coin Change

问题简述:某种货币有n种的币值,给定钱数,求组合数。

问题分析

  这是一个递推组合的问题,关键是找出递推函数来。许多组合问题都有递推式,可以用DP来实现。

程序说明:(略)

 

题记:(略)

参考链接:(略)

 

AC的C++语言程序如下:

 

 

 

/* UVA674 Coin Change */

#include <iostream>
#include <stdio.h>

using namespace std;

const int coins[] = {1, 5, 10, 25, 50};
const int coinslen = sizeof(coins) / sizeof(coins[0]);

const int N = 7489;
int dp[N + 1];

void setdp()
{
    dp[0] = 1;
    for(int i=0; i<coinslen; i++)
        for(int j=coins[i]; j<=N; j++)
            dp[j] += dp[j - coins[i]];
}

int main()
{
    setdp();

    int money;
    while(~scanf("%d", &money))
        printf("%d\n", dp[money]);

    return 0;
}

 

 

 

 

 

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值