UVA299 UVALive5600 Train Swapping【逆序偶+暴力】

281 篇文章 4 订阅
70 篇文章 2 订阅

At an old railway station, you may still encounter one of the last remaining “train swappers”. A trains wapper is an employee of the railroad, whose sole job it is to rearrange the carriages of trains.

  Once the carriages are arranged in the optimal order, all the train driver has to do, is drop the carriages off, one by one, at the stations for which the load is meant.

  The title “train swapper” stems from the first person who performed this task, at a station close to a railway bridge. Instead of opening up vertically, the bridge rotated around a pillar in the center of the river. After rotating the bridge 90 degrees, boats could pass left or right.

  The first train swapper had discovered that the bridge could be operated with at most two carriages on it. By rotating the bridge 180 degrees, the carriages switched place, allowing him to rearrange the carriages (as a side effect, the carriages then faced the opposite direction, but train carriages can move either way, so who cares).

  Now that almost all train swappers have died out, the railway company would like to automate their operation. Part of the program to be developed, is a routine which decides for a given train the least number of swaps of two adjacent carriages necessary to order the train. Your assignment is to create that routine.

Input

The input contains on the first line the number of test cases (N). Each test case consists of two input lines. The first line of a test case contains an integer L, determining the length of the train (0 ≤ L ≤ 50). The second line of a test case contains a permutation of the numbers 1 through L, indicating the current order of the carriages. The carriages should be ordered such that carriage 1 comes first, then 2, etc. with carriage L coming last.

Output

For each test case output the sentence: ‘Optimal train swapping takes S swaps.’ where S is an integer.

Sample Input

3

3

1 3 2

4

4 3 2 1

2

2 1

Sample Output

Optimal train swapping takes 1 swaps.

Optimal train swapping takes 6 swaps.

Optimal train swapping takes 1 swaps.


Regionals 1994 >> Europe - Southwestern


问题链接UVA299 UVALive5600 Train Swapping

问题简述

  一个序列,每次只能交换相邻的两个数,求使得序列变为递增序列需要的最小交换次数。

问题分析

  可以定义逆序对,一个序列中存在a[i]>a[j]且i<j,则a[i]与a[j]构成一对逆序对。

  一个序列的逆序对的总数,就是这个序列的逆序数。

  相邻元素进行交换,那么每次交换序列逆序数必然改变1,而一个递增的序列逆序数为0。因此,最少交换次数即为逆序数,而每次按照逆序对减少的方式交换就得到递增序列。

程序说明

  这个暴力程序虽然可以解决问题,但是如果规模增大则可能出现TLE。有效的方法是采用分治法,使用归并排序的思想来实现。参见参考链接。

题记:(略)

参考链接POJ2299 ZOJ2386 UVA10810 Ultra-QuickSort【逆序偶+归并排序】


AC的C语言程序如下:

/* UVA299 UVALive5600 Train Swapping */

#include <bits/stdc++.h>

using namespace std;

const int N = 50;
int a[N];

int main()
{
    int n, l;

    cin >> n;
    while(n--) {
        cin >> l;
        for(int i = 0; i < l; i++)
            cin >> a[i];

        int cnt = 0;
        for(int i = 0; i < l; i++)
            for(int j = 0; j < i; j++)
                cnt += (a[j] > a[i]);

        cout << "Optimal train swapping takes " << cnt << " swaps." << endl;
    }

    return 0;
}




  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值