POJ1663 HDU1391 ZOJ1414 UVALive2052 Number Steps【数学规律】

509 篇文章 6 订阅
281 篇文章 4 订阅

Number Steps
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 14299 Accepted: 7775

Description

Starting from point (0,0) on a plane, we have written all non-negative integers 0,1,2, … as shown in the figure. For example, 1, 2, and 3 has been written at points (1,1), (2,0), and (3, 1) respectively and this pattern has continued.

在这里插入图片描述

You are to write a program that reads the coordinates of a point (x, y), and writes the number (if any) that has been written at that point. (x, y) coordinates in the input are in the range 0…5000.

Input

The first line of the input is N, the number of test cases for this problem. In each of the N following lines, there is x, and y representing the coordinates (x, y) of a point.

Output

For each point in the input, write the number written at that point or write No Number if there is none.

Sample Input

3
4 2
6 6
3 4

Sample Output

6
12
No Number

Source

Tehran 2000

问题链接 POJ1663 HDU1391 ZOJ1414 UVALive2052 Number Steps
问题简述:(略)
问题分析
    水题,不解释。
程序说明:(略)
参考链接:(略)
题记:(略)

AC的C语言程序如下:

/* POJ1663 HDU1391 ZOJ1414 UVALive2052 Number Steps */

#include <stdio.h>

int main(void)
{
    int t, x, y;
    scanf("%d", &t);
    while(t--) {
        scanf("%d%d", &x, &y);
        if(x == 0 && y == 0)
            printf("0\n");
        else if(x != y && x != y + 2)
            printf("No Number\n");
        else if(x % 2 == 0)
            printf("%d\n", x + y);
        else
            printf("%d\n", x + y - 1);
    }

    return 0;
}
  • 1
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值