【PAT】1001.A+B Format (20)

题目描述:

Calculate a + b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).
翻译:计算a+b然后按照标准格式输出——这代表数字必须被分成3个一组,之间用逗号相连(除非少于4个数字)

INPUT FORMAT:

Each input file contains one test case. Each case contains a pair of integers a and b where -1000000 <= a, b <= 1000000. The numbers are separated by a space.
翻译:每个输入文件包括一组测试数据。每组测试数据包括一对整数a和b, -1000000 <= a, b <= 1000000,数字之间用空格分开。

OUTPUT FORMAT:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.
翻译:对于每组测试数据,你需要在一行内输出a+b的和,和必须用标准格式表示。


Sample Input

-1000000 9


Sample Output

-999,991


解题思路:

将sum保存为数组输出,注意处理正负号。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<cmath>
#include<algorithm>
#define INF 99999999
using namespace std;
int a,b;
int ans[15],ccount=0;
int main(){
  scanf("%d%d",&a,&b);
  int sum=a+b;
  if(sum==0)printf("0\n");
  if(sum<0){
    printf("-");
    sum=-sum;  
  }
  while(sum!=0){
    ans[ccount++]=sum%10;
    sum=sum/10;
  }
  for(int i=ccount-1;i>=0;i--){
    printf("%d",ans[i]);
    if(i!=0&&i%3==0)printf(",");
    if(i==0)printf("\n");  
  } 
  exit(0);
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值