网络流之最大流(增广路)

hdu3459

Flow Problem

Time Limit: 5000/5000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 27520    Accepted Submission(s): 12155


 

Problem Description

Network flow is a well-known difficult problem for ACMers. Given a graph, your task is to find out the maximum flow for the weighted directed graph.

 

 

Input

The first line of input contains an integer T, denoting the number of test cases.
For each test case, the first line contains two integers N and M, denoting the number of vertexes and edges in the graph. (2 <= N <= 15, 0 <= M <= 1000)
Next M lines, each line contains three integers X, Y and C, there is an edge from X to Y and the capacity of it is C. (1 <= X, Y <= N, 1 <= C <= 1000)

 

 

Output

For each test cases, you should output the maximum flow from source 1 to sink N.

 

 

Sample Input

2

3 2

1 2 1

2 3 1

3 3

1 2 1

2 3 1

1 3 1

 

 

Sample Output

Case 1: 1 
Case 2: 2

最大流模板题

 

#include<bits/stdc++.h>
using namespace std;
#define INF 0x3f3f3f3f
int t,ca,cap[20][20],flow[20][20],n,m,a[20],p[20];
//cap 容量
//flow 流量
//a 增广路的最大流量 
int main()
{
	scanf("%d",&t);
	ca=1;
	while(t--)
	{
		memset(cap,0,sizeof(cap));
		memset(flow,0,sizeof(flow));//初始化
		scanf("%d%d",&n,&m);
		for(int i=1; i<=m; i++)
		{
			int x,y,z;
			scanf("%d%d%d",&x,&y,&z);
			cap[x][y]+=z;//x到y的容量增加z 
		}
		int s=1,t=n;//起点为 1  终点为 n 
		int f=0;//最大流的初始值为 0 
		queue<int>q;
		while(1)
		{
			memset(a,0,sizeof(a));
			a[s]=INF;
			q.push(s);
			while(!q.empty())
			{
				int u=q.front();
				q.pop();
				for(int i=1; i<=n; i++)
				{
					if(a[i]==0&&cap[u][i]>flow[u][i])//如果这个点没被走过     并且容量大于现在容量(可以产生增广路) 
					{
						p[i]=u;//让这个点的爸爸是 u 表示 i 是从 u 走过来的  
						q.push(i);//入队 
						a[i]=min(a[u],cap[u][i]-flow[u][i]);
						//上一个点流过来的量为 a[u] 这个点能通过的最大流量为 cap[u][i]-flow[u][i] 
						//去俩者的最小值 为这个点增广路的流量 
					}
				}
			}
			if(a[t]==0) break;//如果这条路没有到终点 那么代表已经不能构成增广路了 
			for(int u=t; u!=s; u=p[u])//从终点开始 往前找到这条增广路的每个点 
			{
				flow[p[u]][u]+=a[t];//正流量加 
				flow[u][p[u]]-=a[t];//负流量减 
			}
			f+=a[t];//总流量加上这条增广路最后的流量 
		}
		printf("Case %d: %d\n", ca++, f);
	}
	return 0;
}

 

 

 

 

 

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值