joj1009(简单的格式控制)

1009: Zorro


ResultTIME LimitMEMORY LimitRun TimesAC TimesJUDGE
3s8192K96051955Standard

Zorro is ready to modernize -- he is tired of hand drawing his giant "Z", and would like to add an educational element. So he wants you to write a program to draw a Z using the lower-case letters of the alphabet in order. If you run out of letters, just continue by following z with a.

Input

A positive integer(<=500) denoting the number of characters across the top of the Z. An input of 0 will indicate that Zorro is done.

Output

The Z, drawn in lowercase alphabetic characters. Each Z should be separated from the previous Z by at least one blank line.

Sample Input

3
30
0

Sample Output

abc
 d
efg

abcdefghijklmnopqrstuvwxyzabcd
                            e
                           f
                          g
                         h
                        i
                       j
                      k
                     l
                    m
                   n
                  o
                 p
                q
               r
              s
             t
            u
           v
          w
         x
        y
       z
      a
     b
    c
   d
  e
 f
ghijklmnopqrstuvwxyzabcdefghij

Hint:

Blank line is used between two Zorros, so there are no extra blank line after last Zorro.

#include<stdio.h>
int main()
{ int n,i,j,k;
  char ch;
  k=1;
  while(scanf("%d",&n),n)
  { ch='a';
    if(k==1)k++;
    else printf("/n"); 
    for(i=1;i<=n;i++)
     { for(j=1;j<=n;j++)
       { if(i==1||i==n)
         {printf("%c",ch);
          ch=ch+1;
          if(ch>'z')
          ch='a';}
          else
          {if(i+j==n+1)
            {printf("%c",ch);ch=ch+1;
            if(ch>'z')
            ch='a';}     
           else
           if(j<=n-i)
             printf(" ");
          }
       }
        printf("/n");
      }
             
   }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值