1044

Collect More Jewels

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6396    Accepted Submission(s): 1470


Problem Description
It is written in the Book of The Lady: After the Creation, the cruel god Moloch rebelled against the authority of Marduk the Creator.Moloch stole from Marduk the most powerful of all the artifacts of the gods, the Amulet of Yendor, and he hid it in the dark cavities of Gehennom, the Under World, where he now lurks, and bides his time.

Your goddess The Lady seeks to possess the Amulet, and with it to gain deserved ascendance over the other gods.

You, a newly trained Rambler, have been heralded from birth as the instrument of The Lady. You are destined to recover the Amulet for your deity, or die in the attempt. Your hour of destiny has come. For the sake of us all: Go bravely with The Lady!

If you have ever played the computer game NETHACK, you must be familiar with the quotes above. If you have never heard of it, do not worry. You will learn it (and love it) soon.

In this problem, you, the adventurer, are in a dangerous dungeon. You are informed that the dungeon is going to collapse. You must find the exit stairs within given time. However, you do not want to leave the dungeon empty handed. There are lots of rare jewels in the dungeon. Try collecting some of them before you leave. Some of the jewels are cheaper and some are more expensive. So you will try your best to maximize your collection, more importantly, leave the dungeon in time.
 

Input
Standard input will contain multiple test cases. The first line of the input is a single integer T (1 <= T <= 10) which is the number of test cases. T test cases follow, each preceded by a single blank line.

The first line of each test case contains four integers W (1 <= W <= 50), H (1 <= H <= 50), L (1 <= L <= 1,000,000) and M (1 <= M <= 10). The dungeon is a rectangle area W block wide and H block high. L is the time limit, by which you need to reach the exit. You can move to one of the adjacent blocks up, down, left and right in each time unit, as long as the target block is inside the dungeon and is not a wall. Time starts at 1 when the game begins. M is the number of jewels in the dungeon. Jewels will be collected once the adventurer is in that block. This does not cost extra time.

The next line contains M integers,which are the values of the jewels.

The next H lines will contain W characters each. They represent the dungeon map in the following notation:
> [*] marks a wall, into which you can not move;
> [.] marks an empty space, into which you can move;
> [@] marks the initial position of the adventurer;
> [<] marks the exit stairs;
> [A] - [J] marks the jewels.
 

Output
Results should be directed to standard output. Start each case with "Case #:" on a single line, where # is the case number starting from 1. Two consecutive cases should be separated by a single blank line. No blank line should be produced after the last test case.

If the adventurer can make it to the exit stairs in the time limit, print the sentence "The best score is S.", where S is the maximum value of the jewels he can collect along the way; otherwise print the word "Impossible" on a single line.
 

Sample Input
  
  
3 4 4 2 2 100 200 **** *@A* *B<* **** 4 4 1 2 100 200 **** *@A* *B<* **** 12 5 13 2 100 200 ************ *B.........* *.********.* *@...A....<* ************
 

Sample Output
  
  
Case 1: The best score is 200. Case 2: Impossible Case 3: The best score is 300.

asd



搜索题,BFS出所有能到达的状态(x,y,目前已经得到的宝石(状态压缩)),如果是终点就刷新答案.

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <queue>

#define MAXN 51
#define MAXM 11

using namespace std;

int n,m,l,k;
char mp[MAXN][MAXN];
int kkke[MAXM];
bool hehe[MAXN][MAXN][1<<MAXM];
int mx[]={ 0, 0, 1,-1};
int my[]={ 1,-1, 0, 0};
int ans;

struct the_step{
	int x;
	int y;
	int zt;
	int sum;
	int cnt;
	the_step()
	{
	}
    the_step(int setx,int sety,int setzt,int setsum,int setcnt)
	{
		x=setx;
		y=sety;
		zt=setzt;
		sum=setsum;
		cnt=setcnt;
	}
	bool done()
	{
		if(x<0||x>=n||y<0||y>=m||mp[x][y]=='*')return true;
		return hehe[x][y][zt];
	}
}nows,nexts;

queue<the_step>q;

void bfs(int x,int y,int zt)
{
	hehe[x][y][zt]=true;
	q.push(the_step(x,y,zt,0,0));
	while(!q.empty())
	{
		nexts=nows=q.front();q.pop();
		nexts.cnt++;
		if(mp[nows.x][nows.y]=='<')ans=max(ans,nows.sum);
	    else if(mp[nows.x][nows.y]>='A'&&mp[nows.x][nows.y]<='J')
	    {
		    if((nows.zt&(1<<(mp[nows.x][nows.y]-'A')))==0)continue;
	        nexts.sum+=kkke[mp[nows.x][nows.y]-'A'];
	        nexts.zt^=1<<(mp[nows.x][nows.y]-'A');
    	}
    	if(nows.cnt>=l)continue;
    	for(int i=0;i<4;i++)
    	{
    		nexts.x=nows.x+mx[i];
    		nexts.y=nows.y+my[i];
    		if(nexts.done())continue;
    		hehe[nexts.x][nexts.y][nexts.zt]=true;
    		q.push(nexts);
    	}
	}
}

void work()
{
	ans=-1;
	memset(hehe,false,sizeof(hehe));
	scanf("%d%d%d%d",&m,&n,&l,&k);
	for(int i=0;i<k;i++)scanf("%d",&kkke[i]);
	int x,y;
	for(int i=0;i<n;i++)
	{
	    scanf("%s",mp[i]);
	    for(int j=0;j<m;j++)
	    {
	    	if(mp[i][j]=='@')
	    	{
	    		x=i;
	    		y=j;
	    	}
	    }
	}
	bfs(x,y,(1<<k)-1);
	if(ans==-1)puts("Impossible");
	else printf("The best score is %d.\n",ans);
}

int main()
{
	freopen("input.txt","r",stdin);
	freopen("output.txt","w",stdout);
	int t;
	scanf("%d",&t);
	puts("Case 1:");
	work();
	for(int i=2;i<=t;i++)
	{
		printf("\nCase %d:\n",i);
		work();
	}
	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值