HDU1325 Is It A Tree? + POJ1308 Is It A Tree?【并查集】

Is It A Tree?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 16258    Accepted Submission(s): 3643


Problem Description
A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties.
There is exactly one node, called the root, to which no directed edges point.

Every node except the root has exactly one edge pointing to it.

There is a unique sequence of directed edges from the root to each node.

For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not.



In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.

 

Input
The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.
 

Output
For each test case display the line ``Case k is a tree." or the line ``Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1).
 

Sample Input
  
  
6 8 5 3 5 2 6 4 5 6 0 0 8 1 7 3 6 2 8 9 7 5 7 4 7 8 7 6 0 0 3 8 6 8 6 4 5 3 5 6 5 2 0 0 -1 -1
 

Sample Output
  
  
Case 1 is a tree. Case 2 is a tree. Case 3 is not a tree.
并查集,注意每个节点的入度<=1。
和HDU1272 小希的迷宫 POJ1308 Is It A Tree? 类似(应该是一样。。)
#include<stdio.h>
#include<string.h>
using namespace std;
int pre[1010];
int book[1010];
int in[1010];
int find(int x)
{
	return pre[x]==x ? x : pre[x]=find(pre[x]);
}
bool merge(int x,int y)
{
	int fx = find(pre[x]);
	int fy = find(pre[y]);
	if(fx != fy)
	{
		pre[fy] = fx;
		return 1;
	}
	return 0;
}
int main()
{
	int a,b;
	int i,j,k = 1;
	int min,max;
	int sum;
	int flag;
	while(scanf("%d%d",&a,&b), a>=0 && b>=0)
	{
		flag = -1;
		sum = 0;
		if(a==0 && b==0)
		{
			printf("Case %d is a tree.\n",k);
			k ++ ;
			continue;
		}
		for(i=0; i<1010; i++)
		{
			pre[i] = i;
		}
		memset(book, 0, sizeof(book));
		memset(in,0,sizeof(in));
		min = 0x7fffffff;
		max = -1;
		while(a || b)
		{
			book[a] = 1;
			book[b] = 1;
			if((a>b?a:b) > max)
			{
				max = (a>b?a:b);
			}
			if((a<b?a:b) < min)
			{
				min = (a<b?a:b);
			}
			if(merge(a, b) == 0)
			{
				flag = 0;
			}
			in[b] ++ ;
			scanf("%d%d",&a, &b);
		}
		if(flag == 0)
		{
			printf("Case %d is not a tree.\n",k);
			k ++ ;
		}
		else
		{
			for(i=min; i<=max; i++)
			{
				if(book[i] && pre[i]==i)
				sum ++ ;
				if(sum > 1)
				{
					break;
				}
				if(in[i] > 1)
				{
					flag = 0;
				}
			}
			if(sum==1 && flag)
			{
				printf("Case %d is a tree.\n",k);
				k ++ ;
			}
			else
			{
				printf("Case %d is not a tree.\n",k);
				k ++ ;
			}
		}
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值