[动态规划]hdu 1003 Max Sum 最大子列

Online Judge Online Exercise Online Teaching Online Contests Exercise Author
F.A.Q
Hand In Hand
Online Acmers
Forum | Discuss
Statistical Charts
Problem Archive
Realtime Judge Status
Authors Ranklist

Search
C/C++/Java Exams
ACM Steps
Go to Job
Contest LiveCast
ICPC@China
Best Coder beta
VIP | STD Contests
Virtual Contests
DIY | Web-DIY beta
Recent Contests
Author jiayoua
Mail Mail 0(0)
Control Panel Control Panel
Sign Out Sign Out
Max Sum

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 242466 Accepted Submission(s): 57246

Problem Description
Given a sequence a[1],a[2],a[3]……a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).

Output
For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.

Sample Input
2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5

Sample Output
Case 1:
14 1 4

Case 2:
7 1 6

package hdu;

import java.util.Scanner;

public class MaxSum {

    public static void main(String[] args) {
        Scanner sc=new Scanner(System.in);
        int t = sc.nextInt();  
        int n,i,j,u,max;
        int[] sum;
        int[] a;
        int[] b;
        for(u=0 ;u<t ;u++){  
             n = sc.nextInt();  
             a=new int[n];
             for(i=0;i<n;i++)
                 a[i]=sc.nextInt();
             max=0;j=0;
             sum=new int[n];
             b=new int[n];
             sum[0]=a[0];
             max=sum[0];
             b[0]=0;
             for(i=1;i<n;i++){
                 if(a[i]>a[i]+sum[i-1]){
                     sum[i]=a[i];
                     b[i]=i;
                 }
                 else{
                     sum[i]=sum[i-1]+a[i];
                     b[i]=b[i-1];
                 }
                 if(sum[i]>max){
                     max=sum[i];j=i;
                 }
             }
             System.out.println("Case "+(u+1)+":");
             System.out.println(max+" "+(b[j]+1)+" "+(j+1));
             if(u!=t-1)
               System.out.println();
        }
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值