Arbitrage HDU

                                                 Arbitrage

                                             Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
                                              Total Submission(s): 3180    Accepted Submission(s): 1445


Problem Description
          Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent.

Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not.
 

Input
           The input file will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency. Exchanges which do not appear in the table are impossible.
Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.

 

Output
For each test case, print one line telling whether arbitrage is possible or not in the format "Case case: Yes" respectively "Case case: No".
 

Sample Input
  
  
3 USDollar BritishPound FrenchFranc 3 USDollar 0.5 BritishPound BritishPound 10.0 FrenchFranc FrenchFranc 0.21 USDollar 3 USDollar BritishPound FrenchFranc 6 USDollar 0.5 BritishPound USDollar 4.9 FrenchFranc BritishPound 10.0 FrenchFranc BritishPound 1.99 USDollar FrenchFranc 0.09 BritishPound FrenchFranc 0.19 USDollar 0
 

Sample Output
  
  
Case 1: Yes Case 2: No
 

Source
 
 
          只能感叹外国就连ACM比赛都是这么符合实际且实用啊。。。。。
题意:
        意思就是叫你算出银行的汇率,判断是否可以赚钱。。哈哈,当然这是非专业的。
        其实题目是告诉我们几个国家之间的汇率,然后叫我们判断他们之间是否有环。且最终通过这种转换能否赚钱。
 其实就是一个有关DP问题于是运用暴力的floyd就可以ko了。
 
#include <iostream>
#include <algorithm>
#include <string>
#include <set>
#include <map>
#include <cstdio>
#include <cstring>
using namespace std;

double dp[31][31];
bool Floyd(int n)
{
    for(int k = 1;k <= n;k++)
    for(int i = 1;i <= n;i++)
      for(int j = 1;j <= n;j++)
        dp[i][j] = max(dp[i][j],dp[i][k]*dp[k][j]);
    for(int i = 1;i <= n;i++)
     if(dp[i][i] > 1)
       return true;
    return false;
}

int main()
{
    double rate;
    int n,m,i,kase = 1;
    while(cin>>n,n)
    {
        string s,a,b;
        map<string,int> mp;
        memset(dp,0,sizeof(dp));
        for(i = 1;i <= n;i++)
        {
            cin>>s;
            mp[s] = i;
        }
        cin>>m;
        for(i = 1;i <= m;i++)
        {
            cin>>a>>rate>>b;
            dp[mp[a]][mp[b]] = rate;
        }
        if(Floyd(n))
          printf("Case %d: Yes\n",kase++);
        else
          printf("Case %d: No\n",kase++);
    }
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值