Strategic Game HDU

                                                Strategic Game

                                                        Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
                                                        Total Submission(s): 3772    Accepted Submission(s): 1663


Problem Description
              Bob enjoys playing computer games, especially strategic games, but sometimes he cannot find the solution fast enough and then he is very sad. Now he has the following problem. He must defend a medieval city, the roads of which form a tree. He has to put the minimum number of soldiers on the nodes so that they can observe all the edges. Can you help him?

Your program should find the minimum number of soldiers that Bob has to put for a given tree.

The input file contains several data sets in text format. Each data set represents a tree with the following description:

the number of nodes
the description of each node in the following format
node_identifier:(number_of_roads) node_identifier1 node_identifier2 ... node_identifier
or
node_identifier:(0)

The node identifiers are integer numbers between 0 and n-1, for n nodes (0 < n <= 1500). Every edge appears only once in the input data.

For example for the tree:



the solution is one soldier ( at the node 1).

The output should be printed on the standard output. For each given input data set, print one integer number in a single line that gives the result (the minimum number of soldiers). An example is given in the following table:
 

Sample Input
  
  
4 0:(1) 1 1:(2) 2 3 2:(0) 3:(0) 5 3:(3) 1 4 2 1:(1) 0 2:(0) 0:(0) 4:(0)
 

Sample Output
  
  
1 2
 

Source
 
 
 
 
题意:
             一道很明了的二分匹配图的最小点覆盖问题;
         最小点覆盖 == 最大匹配数;    想知道为什么的话,可以看一下我学长的博客:链接地址
        题目意思就不啰嗦了,自己看吧。要注意的就是,该题是一个双向图,所以结果要除以2;还有就是数据太大,要用到邻接表的使用。不懂的使用邻接表的话自己去上网查看学习吧,或者本人博客中也有介绍邻接表的使用。
 
 
#include <stdio.h>
#include <string.h>
#define CL(x,v);memset(x,v,sizeof(x));

const int maxn = 1500 + 10;
int n,top,link[maxn];
bool used[maxn];
int next[maxn*maxn],head[maxn*maxn],num[maxn*maxn];

int Find(int u)
{
     for(int i = head[u];i != -1;i = next[i])
     {
         int v = num[i];
         if(!used[v])
         {
             used[v] = u;
             if(link[v] == -1||Find(link[v]))
             {
                 link[v] = u;
                 return 1;
             }
         }
     }
     return 0;
}

int KM()
{
    int res = 0;
    CL(link,-1);
    for(int u = 0;u < n;u++)
    {
        CL(used,0);
        res += Find(u);
    }
    return res;
}

int main()
{
    int m,i,j,index,vex;
    while(~scanf("%d",&n))
    {
        top = 0;
        CL(head,-1);
        for(i = 0;i < n;i++)
        {
            scanf("%d:(%d)",&index,&m);
            for(j = 0;j < m;j++)
            {
                scanf("%d",&vex);
                next[top] = head[index];
                num[top] = vex;
                head[index] = top++;
                next[top] = head[vex];
                num[top] = index;
                head[vex] = top++;
            }
        }
        printf("%d\n",KM()/2);
    }
    return 0;
}

         
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值