求后序遍历序列的第k个结点值(二叉树)

1.题目:


 Problem Description

设有一棵二叉树,其节点值为字符型并假设各值互不相等,采用二叉链表存储表示。现输入其扩展二叉树的前序遍历序列,要求建立该二叉树,并输出其后序遍历序列的第k个结点值(假设该值一定存在)。


 Input

第一行为一个整数n,表示以下有n组数据,每组数据占两行,第一行为一个整数k(1<=k<=二叉树中的结点总数),第二行为扩展二叉树的前序遍历序列。


 Output

输出该二叉树后序遍历序列的第k个结点值。


 Sample Input

2
1
AB#D##C##
4
ABD##E##C#F##


 Sample Output

D
F


2.参考代码:

#include <iostream>
using namespace std;

char ans[1111];
int t;
struct BiNode{
	char data;
	BiNode* lchild,* rchild;
};

class BiTree{
private:
	BiNode* root;
	BiNode* Creat();
	void Release(BiNode* root);
public:
	BiTree();
	~BiTree();
	BiNode* GetRoot(){
		return root;
	}
	void PostOrder(BiNode* root);
};

BiNode* BiTree::Creat(){
	BiNode* root=new BiNode;
	char ch;
	cin>>ch;
	if(ch=='#')
		root=NULL;
	else{
		root->data=ch;
		root->lchild=Creat();
		root->rchild=Creat();
	}
	return root;
}

void BiTree::Release(BiNode* root){
	if(root){
		Release(root->lchild);
		Release(root->rchild);
		delete root;
	}
}

BiTree::BiTree(){
	root=Creat();
}

BiTree::~BiTree(){
	Release(root);
}

void BiTree::PostOrder(BiNode* root){
	if(root==NULL)
		return ;
	else{
		PostOrder(root->lchild);
		PostOrder(root->rchild);
		ans[t++]=root->data;
	}
}

int main()
{
	int n,x;
	cin>>n;
	while(n--)
	{
		cin>>x;
		BiTree bt;
		BiNode* root=bt.GetRoot();
		bt.PostOrder(root);
		cout<<ans[x-1]<<endl;
		t=0;
	}
	return 0;
}




  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值