1.题目:
Problem Description
Give you the width and height of the rectangle,darw it.
Input
Input contains a number of test cases.For each case ,there are two numbers n and m (0 < n,m < 75)indicate the width and height of the rectangle.Iuput ends of EOF.
Output
For each case,you should draw a rectangle with the width and height giving in the input.after each case, you should a blank line.
Sample Input
3 2
Sample Output
+---+
| |
| |
+---+
2.参考代码:
#include <iostream>
using namespace std;
int main()
{
int w, h, i, j, num = 0;
while (cin >> w >> h) {
for (i = 0; i < h + 2; i++) {
for (j = 0; j < w + 2; j++) {
if ((i == 0 && (j == 0 || j == w + 1)) || (i == h + 1 && (j == 0 || j == w + 1)))
cout << '+';
else if (i == 0 || i == h + 1) {
// for(k=0;k<w/2;k++) ///这句话不要加,不然会WA
cout << '-';
} else if (j == 0 || j == w + 1) {
//for(k=0;k<h/2;k++) ///这句话不要加,不然会WA
cout << '|';
} else
cout << ' ';
}
cout << endl;
}
cout << endl;
}
return 0;
}