Picture

1.题目:

Problem Description

Give you the width and height of the rectangle,darw it.

Input

Input contains a number of test cases.For each case ,there are two numbers n and m (0 < n,m < 75)indicate the width and height of the rectangle.Iuput ends of EOF.

Output

For each case,you should draw a rectangle with the width and height giving in the input.after each case, you should a blank line.

Sample Input

3 2

Sample Output

+---+
|   |
|   |
+---+

 

2.参考代码:

 

 

#include <iostream>
using namespace std;

int main()
{
    int w, h, i, j, num = 0;

    while (cin >> w >> h) {
        
        for (i = 0; i < h + 2; i++) {
            for (j = 0; j < w + 2; j++) {
                if ((i == 0 && (j == 0 || j == w + 1)) || (i == h + 1 && (j == 0 || j == w + 1)))
                    cout << '+';
                else if (i == 0 || i == h + 1) {
                    //  for(k=0;k<w/2;k++)   ///这句话不要加,不然会WA
                    cout << '-';
                } else if (j == 0 || j == w + 1) {
                    //for(k=0;k<h/2;k++)   ///这句话不要加,不然会WA
                    cout << '|';
                } else
                    cout << ' ';
            }
    
            cout << endl;
        }
        cout << endl;
    }

    return 0;
}


 

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值